Enable silent-rules for compilation
[fsviewer.git] / FSViewer.app-0.2.6.spec
blobb574710f1850268fc986d2a92f895e93a2b1bfe0
1 %define GNUstepApps /usr/X11R6/GNUstep/Apps
3 Summary: FSViewer is a NeXT FileViewer lookalike for Window Maker.
4 Summary(de): Dateisystembrowser aehnlich dem NeXT FileViewer.
5 Name: FSViewer.app
6 Version: 0.2.6
7 Release: 1%{?dist}
8 Prefix: /usr
9 License: GPL
10 Group: Productivity/File utilities
11 URL: http://www.bayernline.de/~gscholz/linux/fsviewer/
12 Vendor: Guido Scholz <guido.scholz@bayernline.de>
13 Source: fsviewer-app-%{version}.tar.bz2
14 BuildRoot: %{_tmppath}/%{name}-%{version}-root
15 Requires: WindowMaker >= 0.90
16 Distribution: SuSE 10.1
18 %description
19 FSViewer is a NeXT FileViewer lookalike for Window Maker. Viewing is
20 currently supported via browser and list mode. It has been written in C
21 using the WINGs library.
23 Authors:
24 ========
25 George Clernon <clernong@tinet.ie>
26 Guido Scholz <guido.scholz@bayernline.de> (port to Window Maker 0.80.0)
28 %description -l de
29 FSViewer ist ein Dateisystembrowser, der sich optisch und funktionell
30 stark an den NeXT FileViewer anlehnt. Die Dateiansicht besteht derzeit in
31 Form einer "Browser"- und einer Listenansicht. Das Programm wurde in C
32 unter Benutzung der WINGs-Bibliothek geschrieben.
34 Autoren:
35 ========
36 George Clernon <clernong@tinet.ie>
37 Guido Scholz <guido.scholz@bayernline.de> (Portierung nach Window Maker 0.80.0)
39 %prep
40 %setup -q -n fsviewer-app-%{version}
42 %build
43 CFLAGS=$RPM_OPT_FLAGS \
44 ./configure --prefix=%{_prefix} \
45 --mandir=%{_mandir} \
46 --with-appspath=%{GNUstepApps}
47 make
49 %install
50 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
51 make DESTDIR=$RPM_BUILD_ROOT install-strip
53 install -d $RPM_BUILD_ROOT/%{_docdir}/%{name}
55 install -d $RPM_BUILD_ROOT/%{GNUstepApps}/%{name}/tiff
56 install -m 644 tiff/*.tif $RPM_BUILD_ROOT/%{GNUstepApps}/%{name}/tiff
58 install -d $RPM_BUILD_ROOT/%{GNUstepApps}/%{name}/xpm
59 install -m 644 xpm/*.xpm $RPM_BUILD_ROOT/%{GNUstepApps}/%{name}/xpm
61 %clean
62 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
64 %files
65 %defattr(-,root,root)
66 %{GNUstepApps}/%{name}
67 %{_prefix}/share/locale/*/LC_MESSAGES/FSViewer.mo
68 %docdir %{_mandir}/man1/*
69 %{_mandir}/man1/*
70 %{_docdir}/%{name}
71 %doc defs/chdef docs/* AUTHORS COPYING ChangeLog INSTALL NEWS README
73 %changelog
74 * Sun Oct 14 2007 Guido Scholz <guido.scholz@bayernline.de>
75 - update to version 0.2.6
76 - spec-File modifications for SuSE 10.1
78 * Sat Jun 12 2004 Guido Scholz <guido.scholz@bayernline.de>
79 - spec-File Modifications for SuSE 9.0
81 * Tue Dec 24 2002 Guido Scholz <guido.scholz@bayernline.de>
82 - Added menu modification scripts for SuSE 8.0
84 * Sun Dec 15 2002 Guido Scholz <guido.scholz@bayernline.de>
85 - New release FSViewer.app 0.2.5
87 * Sun Nov 10 2002 Guido Scholz <guido.scholz@bayernline.de>
88 - New release FSViewer.app 0.2.4
90 * Fri Nov 01 2002 Guido Scholz <guido.scholz@bayernline.de>
91 - New release FSViewer.app 0.2.3f
93 * Mon Feb 25 2002 Guido Scholz <guido.scholz@bayernline.de>
94 - New release FSViewer.app 0.2.3d
96 * Sat Jan 05 2002 Guido Scholz <guido.scholz@bayernline.de>
97 - Adaption to WindowMaker 0.80.0 (removed libProplist dependency,
98 changed icon handling)
100 * Fri Oct 22 1999 Ryan Weaver <ryanw@infohwy.com>
101 [fsviewer-0.2.3-1]
102 - Changed MAXINT to INT_MAX for NetBSD v1.3.2
103 - Added Preferences Window
104 - Fixed bug in FSGetStringForName, if the returned value is NULL,
105 wstrdup is not called.
106 - Fixed bug in FSCreatePixmapWithBacking*** when image is bigger
107 than backing.
108 - Created Icon Selection Dialog.
109 - Updated Icon Inspector to reflect look of Icon Selection Dialog.
110 - Set window level for some dialogues.
111 - Updated Edit|View Inspectors to save the extn into the EXTN
112 defaults file entry.
113 - Modified chdefs to make the latest changes the necessary
114 changes to the defaults file.
115 - Added DisplayMCListPixmap variable to turn on/off display of pixmaps
116 indicating file/directory. The list runs better with it off!
117 - Add check for empty clientData in paintItem of FSMCList.
119 * Mon Aug 2 1999 Ryan Weaver <ryanw@infohwy.com>
120 [fsviewer-0.2.2-1]
121 - Added icons for files and directories in list view
122 - Plugged a few memory leaks found by Electric Fence
123 - Insertion/Deletion of files now updates all views
124 - Changed the configure script to use get-wraster-flags,
125 this will hopefully fix most "can't find library" problems
126 - Changed listview parsing method.
127 - Applied a patch by Igor Roboul to FSViewer.c and iconInspector.c
129 * Fri Jul 2 1999 Ryan Weaver <ryanw@infohwy.com>
130 [fsviewer-0.2.1-1]
131 - FSViewer now compiles with WM 0.60
132 - Added a preliminary list view. This is really for v0.3.0 but I left
133 it in anyway.
134 - FSGetStringFor*** now returns a duplicated string.
135 - wmallocing memory with (Disk) instead of (Disk *)
136 - Fixed icon naming problem when the icon changes but the popup doesn't
138 * Fri May 28 1999 Ryan Weaver <ryanw@infohwy.com>
139 [fsviewer-0.2.0-2]
140 - OPPS! Now installing in /usr/GNUstep instead of my typo of /usr/GNUStep.
142 * Tue May 25 1999 Ryan Weaver <ryanw@infohwy.com>
143 [fsviewer-0.2.0-1]
144 - Patched Makefile.in's to allow me to install into an arbitrary prefix dir.
145 - FSViewer.app-0.2.0 (19990507)
146 - Added dialog to prompt for settings with respect to unknown
147 file types.
148 - Added app specific alert panel.
149 - Added in fallback condition that if the creation of an icon fails
150 it defaults to the file_plain xpm.
151 - Automagically generate a defaults file if one doesn't exist.
152 - Rewrote proplist code to use WMUserDefaults
153 - Reorganised app/file extension association. The extension now
154 has a viewer/editor exec string associated with it.
155 - Inspector panels resized, they look better now :)
156 - Removed Extension Inpector Panel.
157 - Fixed bug wrt adding to shelf from column 0.
158 - Shelf item background momentarily changes when clicked.
159 - "/" cannot be added to the shelf.
160 - Implemented basic preferences window.
161 - Sort file view by ascending or descending and by files first,
162 directories first or all jumbled up!
163 - Modified the backing pixmap for the shelf and the scrollview.
164 A 64x64 pixmap is combined with the original pixmap. This allows
165 buttons to be used as the widget holder for the icons in the
166 scrollview.
167 - The browser (kinda) mimics the NeXT movements i.e. it only scrolls
168 the browser if a file/folder is selected that is outside the current
169 columns.
170 - Added FSFileButton widget to provide shaped background and DnD
171 related stuff.
172 - Rewrote shelf to use FSFileButton widget
173 - Updated FSBrowser to reflect changes in the WINGs library
174 - Implemented Path View using frames and file buttons
175 - Fleshed out the main menu and populated some options
176 - Added in platform specific #defines for memory and disk calculations
177 - Added in DnD support. OffiX library ported by Igor Roboul.
178 - Added in code to change the cursor in the Dnd code and removed the
179 root drop checks
180 - Modified the main menu to accept only Alt+key_press or
181 Meta+key_press depending on keyboard setup.
182 - Created PathView widget based on wbrowser. It provides better
183 support for window/column resizing.
184 - Free the FSFileInfo list after populating the browser. This should
185 plug a memory leak.
186 - Provided the ability to resize the columns
187 - Added double click to browser items
188 - Added tooltip like view to the FSFileButton widget. Popups when the
189 text is to wide for the button.
190 - Added Update Viewer menu call.
191 - Browser can now be updated based on file action (copy/delete etc.)
192 - Added in xmodifier code from WPRefs/WM to provide correct Alt|Meta
193 key support.
194 - Added chdef to change the old defaults file to the new format.
195 - Added option to disable the timestamp from the Inspector Window.
196 - Added support for formats (besides XPM and TIFF) supported by wmlib.
197 Need to uncomment the code in FSUtils to use.
198 - Added in front end to find and locate. Uses hardcoded defaults for
199 the moment, this will change in the next rev.
200 - Now pass executable name to WMInitialiseApplication instead of full
201 pathname.
202 - cdef now includes update for ROOT icon entry.
204 * Wed Feb 23 1999 Ryan Weaver <ryanw@infohwy.com>
205 [fsviewer-0.1.1-1]
206 - FSViewer.app-0.1.1 (19990223)
207 - Commented out FSDisk related code in FSUtils.c, should fix
208 some multi-platform compilation problems.
209 - Added a patch to automatically detect HOME dir.
210 - Fixed a bug that crashes the app if the inital path contains a
211 long path component.
212 - Zombie process are now cleaned up.
213 - Fixed WMJustified bug (should be WAJustified) in inspector.c and
214 iconInspector.c
215 - Implemented Revert in attributes inspector.
216 - Initial launch path is now the users home dir.
217 - Now checks return value of getpwuid and getgrgid calls in
218 attribsInspector.c, used to seg fault if either group or user
219 was unknown.
220 - Disabled hiding of app via 'h' key, leaving it up to Window Maker
221 and changed the quit key from 'q' to '^q' to prevent accidents :).
222 - Added in a "Console" menu option under the "Tools" menu. It launches
223 an xterm at the current directory.
224 - The window and miniwindow icon titles are set with the current
225 selection.
226 - Added in rudimentary magic files support. This allows certain kinds
227 of unknown files to be viewed.
228 - Fixed bug wrt to displaying/hiding dot files.
229 - Added in file filtering.
231 * Wed Feb 3 1999 Ryan Weaver <ryanw@infohwy.com>
232 [fsviewer-0.1.0-1]
233 - FSViewer.app-0.1.0 (19990201)
234 - Reorganised the initialisation of the app.
235 - Multiple Windows can be opened.
236 - Display hidden files.
237 - Permissions can be set from attributes inspector.
238 - Icons can be set for extensions from File Extension
239 inspector.
240 - Added legal panel.
241 - Added info panel (broke app for other platforms though).
242 - Tidied up code for file browsing to easily add other
243 views.
244 - In the process of moving odds and ends to FSUtils.c
245 - Rewrote the scrollview code that displays the current path.
246 - The window(s) can be resized in both width and height.
247 - Using nodename from utsname struct as the hostname.
248 - Using timestampWidget instead of timestamp in attribsInspector
249 as it can display the year.
250 - Updated the configure script to take into account datadir value
251 when generating the FSViewer default file.
252 - Added in Cut, Copy, Paste, Rename, Delete and Link.
253 - Inspector window now updates automatically if it is open.
254 - Added in the shelf.
255 - Added new file/directory creation.
256 - Before launching an app, the pwd is changed to the selected dir.
257 - Added in the Tools submenu and moved the Inspector there.
258 - Created icons and src sub directories.
260 * Fri Dec 18 1998 Ryan Weaver <ryanw@infohwy.com>
261 [fsviewer-0.0.2-1]
262 - FSViewer.app-0.0.2 (19981217)
263 - Added in more checks to the configure script.
264 - Replaced basename with GetNameFromPathname.
265 - Using strrchr instead of rindex.
266 - Searches the Window Maker defaults domain for IconPath
267 instead of PixmapPath
268 - Using "/" if environment variable HOSTNAME is not set.
269 - Added command line option to start FSViewer at a specified
270 path.
272 * Thu Dec 10 1998 Ryan Weaver <ryanw@infohwy.com>
273 [fsviewer-19981214-1]
274 - First RPM
275 - 14/12/98
276 The source code for FSViewer is now available. This is a preliminary
277 release. It's not guaranteed to do anything. Hopefully it will compile and
278 run straight out of the box. I'm currently working on getting it to compile
279 on my Sun at work.