fmtools version 1.0.
[fmtools.git] / debian / rules
blob35fbe038381754885d108d6d8ad3539aae5581fc
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # Modified for fmtools by Ben Pfaff.
4 # This file is public domain software, originally written by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 # This is the debhelper compatibility version to use.
10 export DH_COMPAT=3
12 build: build-stamp
13 build-stamp:
14 dh_testdir
16 $(MAKE)
18 touch build-stamp
20 clean:
21 dh_testdir
22 dh_testroot
23 rm -f build-stamp
25 # Add here commands to clean up after the build process.
26 -$(MAKE) clean
28 dh_clean
30 install: build
31 dh_testdir
32 dh_testroot
33 dh_clean -k
34 dh_installdirs usr/bin
35 install -s fm fmscan debian/fmtools/usr/bin
37 # Build architecture-independent files here.
38 binary-indep: build install
39 # We have nothing to do by default.
41 # Build architecture-dependent files here.
42 binary-arch: build install
43 dh_testdir
44 dh_testroot
45 dh_installdocs README
46 dh_installexamples
47 dh_installmenu
48 dh_installcron
49 dh_installman fm.1 fmscan.1
50 dh_installinfo
51 dh_installchangelogs CHANGES
52 dh_link
53 dh_strip
54 dh_compress
55 dh_fixperms
56 dh_installdeb
57 dh_shlibdeps
58 dh_gencontrol
59 dh_md5sums
60 dh_builddeb
62 binary: binary-indep binary-arch
63 .PHONY: build clean binary-indep binary-arch binary install