Update Debian packaging.
[fmtools.git] / debian / rules
blob30e77a8ecdd5e26b1a462f84d770ef3c34616479
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # Modified for fmtools by Ben Pfaff.
4 # This file is public domain software, originally written by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 build: build-stamp
10 build-stamp:
11 dh_testdir
13 ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib
14 $(MAKE)
16 touch build-stamp
18 clean:
19 dh_testdir
20 dh_testroot
21 rm -f build-stamp
22 [ ! -f Makefile ] || $(MAKE) distclean
23 dh_clean
25 install: build
26 dh_testdir
27 dh_testroot
28 dh_prep
29 dh_installdirs usr/bin
30 install -s fm fmscan debian/fmtools/usr/bin
32 # Build architecture-independent files here.
33 binary-indep: build install
34 # We have nothing to do by default.
36 # Build architecture-dependent files here.
37 binary-arch: build install
38 dh_testdir
39 dh_testroot
40 dh_installdocs README
41 dh_installexamples
42 dh_installmenu
43 dh_installcron
44 dh_installman fm.1 fmscan.1
45 dh_installinfo
46 dh_installchangelogs
47 dh_link
48 dh_strip
49 dh_compress
50 dh_fixperms
51 dh_installdeb
52 dh_shlibdeps
53 dh_gencontrol
54 dh_md5sums
55 dh_builddeb
57 binary: binary-indep binary-arch
58 .PHONY: build clean binary-indep binary-arch binary install