new gcc snapshot
[dottout.git] / net-im / emesene / files / sys-devel / gcc / gcc-4.3.0_alpha20080125.ebuild
blobbaf2975638e24efbd3f7a82efa0c06134f88d42a
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.0_alpha20070112.ebuild,v 1.1 2007/01/18 05:13:42 vapier Exp $
5 ETYPE="gcc-compiler"
6 GCC_FILESDIR=${PORTDIR}/sys-devel/gcc/files
8 inherit toolchain
10 DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
12 LICENSE="GPL-2 LGPL-2.1"
13 KEYWORDS="-*"
15 RDEPEND=">=sys-libs/zlib-1.1.4
16 || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
17 virtual/libiconv
18 >=dev-libs/gmp-4.2.1
19 >=dev-libs/mpfr-2.2.0_p10
20 !build? (
21 gcj? (
22 gtk? (
23 || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
24 >=x11-libs/gtk+-2.2
25 x11-libs/pango
27 >=media-libs/libart_lgpl-2.1
29 >=sys-libs/ncurses-5.2-r2
30 nls? ( sys-devel/gettext )
32 DEPEND="${RDEPEND}
33 >=sys-apps/texinfo-4.2-r4
34 >=sys-devel/bison-1.875
35 >=${CATEGORY}/binutils-2.16.1"
36 PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
37 if [[ ${CATEGORY} != cross-* ]] ; then
38 PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
41 pkg_setup() {
42 if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
43 die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
47 src_unpack() {
48 gcc_src_unpack
50 use vanilla && return 0
52 # Fix cross-compiling
53 epatch "${GCC_FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
56 pkg_postinst() {
57 toolchain_pkg_postinst
59 einfo "This gcc-4 ebuild is provided for your convenience, and the use"
60 einfo "of this compiler is not supported by the Gentoo Developers."
61 einfo "Please file bugs related to gcc-4 with upstream developers."
62 einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"