new gcc snapshot
[dottout.git] / net-im / emesene / files / net-im / gyachi / gyachi-9999.ebuild
blobf424b4c57c7a68c52b97217b6b093223df740400
1 # Copyright 1999-2004 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-im/gyachi/gyachi-9999.ebuild $
5 inherit autotools eutils distutils cvs
7 DESCRIPTION="GTK+-based Yahoo! chat client which is a fork off of Gyach Enhanced"
8 HOMEPAGE="http://gyachi.sourceforge.net/"
9 KEYWORDS="~x86"
10 IUSE="gnome"
11 LICENSE="GPL-2"
12 SLOT="0"
14 ECVS_SERVER="gyachi.cvs.sourceforge.net:/cvsroot/gyachi"
15 ECVS_MODULE="gyachi"
17 DEPEND="virtual/libc
18 media-libs/jasper
19 =gnome-extra/gtkhtml-2*
20 =x11-libs/gtk+-2*
21 dev-libs/libmcrypt
22 media-gfx/imagemagick"
24 S="${WORKDIR}/${PN}"
26 src_unpack() {
27 cvs_src_unpack
30 src_compile() {
31 cd ${S}
32 myconf="--disable-plugin-gpgme --disable-plugin-xmms"
33 ./autogen.sh
34 econf ${myconf} || die "econf failed"
35 emake || die "emake failed"
38 src_install() {
39 make DESTDIR=${D} install || die "install failed"