new gcc snapshot
[dottout.git] / net-im / emesene / files / net-im / emesene / emesene-9999.ebuild
blob2acfd116aa59806bddde8274a783ce90d922ce68
2 # Copyright 1999-2006 Gentoo Foundation
3 # Distributed under the terms of the GNU General Public License v2
5 ESVN_REPO_URI="https://emesene.svn.sourceforge.net/svnroot/emesene/trunk/emesene"
6 ESVN_PROJECT="emesene"
8 inherit subversion eutils
10 DESCRIPTION="Platform independent MSN Messenger client written in Python+GTK"
11 HOMEPAGE="http://www.emesene.org"
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
18 DEPEND=">=dev-lang/python-2.4.3
19 >=x11-libs/gtk+-2.8.20
20 >=dev-python/pygtk-2.8.6
23 RDEPEND="${DEPEND}"
26 pkg_setup() {
27 ewarn "This is a LIVE SVN ebuild."
28 ewarn "That means there are NO promises it will work."
31 src_install() {
32 cd ${S}
33 dodir /usr/share/emesene
34 insinto /usr/share/emesene
35 doins -r ./*
36 dodir /usr/bin
37 dosym /usr/share/emesene/emesene /usr/bin
38 exeinto /usr/share/emesene
39 doexe emesene
40 newicon ${S}/themes/default/icon96.png ${PN}.png
41 make_desktop_entry emesene "EmeSeNe" ${PN}.png
44 pkg_postinst() {
45 ewarn "Remember, this stuff is SVN only code so dont cry when"
46 ewarn "I break you :)."
47 ewarn "If you want to report bugs, go to our forum at http://emesene.org/forums"