new gcc snapshot
[dottout.git] / net-im / emesene / files / media-tv / sopcast / sopcast-1.1.1.ebuild
blobf4d24da8c964a7fb2bc5c359b9efc1a1358f90eb
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils
7 MY_P="sp-auth"
8 S="${WORKDIR}/${MY_P}"
10 DESCRIPTION="SopCast free P2P Internet TV binary"
11 LICENSE="SopCast-unknown-license"
12 HOMEPAGE="http://www.sopcast.com/"
13 SRC_URI="http://download.sopcast.com/download/${MY_P}.tgz"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
19 # All dependencies might not be listed, since the binary blob's homepage only lists libstdc++
20 RDEPEND=">=virtual/libstdc++-3.3"
22 DEPEND="${RDEPEND}"
26 src_unpack() {
27 ewarn "SopCast binary blob is distributed without version info in its package."
28 ewarn "Thus, in case this ebuild fails, you might want to remove your " $MY_SRC
29 ewarn "from /usr/portage/distfiles and check whether they have release a newer"
30 ewarn "version on their homepage at"
31 ewarn $HOMEPAGE
33 unpack ${A}
36 src_install() {
37 cd ${S}
38 dobin sp-sc-auth
39 # we need to make the above available for older stuff expecting to find it with the old name
40 dosym /usr/bin/sp-sc-auth /usr/bin/sp-sc
41 dobin sp-so-auth
42 dodoc Readme