new gcc snapshot
[dottout.git] / net-im / emesene / files / media-sound / mac / mac-3.99.4.5.ebuild
blob86a13fd7ea66fd0c789c4c9f2221af34d104d3b5
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils
6 MY_PV="3.99-u4-b5"
8 DESCRIPTION="Codec and console-tool for lossless Monkey's Audio (.ape)"
9 HOMEPAGE="http://sourceforge.net/projects/mac-port/"
10 SRC_URI="mirror://sourceforge/mac-port/${PN}-${MY_PV}.tar.gz"
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
16 IUSE="compability"
18 DEPEND=">=dev-lang/nasm-0.98.39"
20 S="${WORKDIR}/${PN}-${MY_PV}"
22 src_unpack() {
23 unpack ${A}
24 cd "${S}"
27 src_compile() {
28 econf \
29 --disable-dependency-tracking \
30 $( use_enable compability backward ) \
31 || die "econf failed"
33 emake || die "emake failed"
36 src_install() {
37 make DESTDIR=${D} install || die
39 dodoc AUTHORS ChangeLog README NEWS TODO