new gcc snapshot
[dottout.git] / net-im / emesene / files / media-libs / libgpod / libgpod-9999.ebuild
blob31f98f2b45b48aa06db3786e651fb2bebdcf6022
1 ## Copyright 1999-2004 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 inherit subversion eutils
6 ESVN_REPO_URI="http://gtkpod.svn.sourceforge.net/svnroot/gtkpod/libgpod/trunk"
7 ESVN_PROJECT="libgpod"
8 DESCRIPTION="iPod library"
9 HOMEPAGE="http://gtkpod.sourceforge.net"
11 IUSE="sg3"
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="~x86"
16 DEPEND=">=sys-apps/dbus-0.50
17 >=sys-apps/hal-0.5.4
18 >=sys-apps/eject-2.1.0
19 >=dev-util/subversion-1.4.2
20 sg3? ( sys-apps/sg3_utils)" # Thanks to Douglas
22 pkg_setup() {
23 ewarn "This is a LIVE SVN ebuild."
24 ewarn "That means there are NO promises it will work."
28 src_compile() {
29 ./autogen.sh
30 econf || die "configure failed"
31 emake || die "make failed"
34 src_install() {
35 einstall || die "install failed"
38 pkg_postinst() {
39 ewarn ""
40 ewarn "sg3 USE is higly recommended to solve firewire ID problem"
41 ewarn "with newer Ipods. Next, run the sg3_utils':"
42 ewarn "ipod-read-sysinfo-extended <device> <mountpoint>"
43 ewarn ""