updated emesene
[dottout.git] / media-tv / sopcast-bin / sopcast-bin-3.2.6.ebuild
blob532226aaf40d069a053ea6122ca364ce6d7d852c
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=2
7 inherit eutils
9 MY_P="sp-auth"
11 DESCRIPTION="SopCast free P2P Internet TV binary"
12 LICENSE="SopCast-unknown-license"
13 HOMEPAGE="http://www.sopcast.com/"
14 SRC_URI="http://sopcast-player.googlecode.com/files/${MY_P}-${PV}.tar.gz"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19 RESTRICT="strip"
21 # All dependencies might not be listed, since the binary blob's homepage only lists libstdc++
22 RDEPEND="amd64? ( app-emulation/emul-linux-x86-compat )
23 x86? ( >=virtual/libstdc++-3.3 )"
25 DEPEND="${RDEPEND}"
27 S=${WORKDIR}/${MY_P}
29 src_install() {
30 exeinto /opt/${PN}
31 newexe sp-sc-auth ${PN} || die "newexe failed"
32 dosym /opt/${PN}/${PN} /usr/bin/${PN}
33 dodoc Readme || die "dodoc failed"