updated emesene
[dottout.git] / media-tv / em28xx-new / em28xx-new-0.0.20090403.36638895894479.ebuild
blob36f7c6e32e14b43567ea5f084afbb7b400bd0a35
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit linux-info linux-mod mercurial versionator
7 printf -v EHG_REVISION '%012x' "$(get_version_component_range 4)"
8 EHG_REPO_URI="http://mcentral.de/hg/~mrec/em28xx-new/"
9 EHG_PULL_CMD="hg pull --force --quiet" # necessary until bug 264921 is fixed
11 DESCRIPTION="next generation em28xx driver including dvb support"
12 HOMEPAGE="http://mcentral.de/"
13 SRC_URI=""
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
19 S=${WORKDIR}/${PN}
21 CONFIG_CHECK="VIDEO_V4L2 DVB_CORE"
23 pkg_setup() {
24 linux-mod_pkg_setup
25 if kernel_is lt 2 6 21; then
26 eerror "You need at least kernel 2.6.21"
27 die "Kernel too old"
30 if linux_chkconfig_present VIDEO_EM28XX; then
31 ewarn "In-kernel em28xx drivers enabled, disable or remove them from"
32 ewarn "/lib/modules/${KV_FULL} if you experience problems."
36 src_compile() {
37 set_arch_to_kernel
38 emake || die "Compiling kernel modules failed"
41 src_install() {
42 insinto /lib/modules/${KV_FULL}/empia
43 local extglob_bak=$(shopt -p extglob)
44 shopt -s extglob # portage disables bash extglob in ebuilds
45 doins $(echo {!(precompiled)/,}*.ko)
46 eval ${extglob_bak} # restore previous extglob status