added virtualbox-bin-3.0.2 and modules
[dottout.git] / media-libs / farsight2 / farsight2-0.0.9.ebuild
blob66d278bfa05093541c9e6c8028e5bd9334a6efa7
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-libs/farsight/farsight-0.1.26.ebuild,v 1.2 2008/04/07 13:27:34 tester Exp $
5 DESCRIPTION="FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
6 HOMEPAGE="http://farsight.freedesktop.org/"
7 SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
8 #EDARCS_REPO_URI="http://projects.collabora.co.uk/darcs/farsight/farsight"
10 LICENSE="LGPL-2.1"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="jingle doc test"
13 # msn yahoo
14 SLOT="0"
16 RDEPEND="=media-libs/gstreamer-0.10*
17 >=media-libs/gstreamer-0.10.17
18 >=media-plugins/gst-plugins-farsight-0.12.7-r1
19 >=media-libs/gst-plugins-base-0.10.17
20 >=dev-python/gst-python-0.10.10
21 >=dev-libs/glib-2.6
22 !<net-voip/telepathy-stream-engine-0.5.0
23 dev-libs/libxml2
24 doc? ( >=dev-util/gtk-doc-1.5 )
25 jingle? ( >=net-libs/libjingle-0.3.11 )
26 test? ( >=dev-libs/check-0.9.4 )"
28 DEPEND="${RDEPEND}
29 dev-util/pkgconfig
30 =media-libs/gst-plugins-base-0.10*
31 =media-libs/gst-plugins-good-0.10*
32 =media-plugins/gst-plugins-ffmpeg-0.10*"
34 src_compile() {
35 # I'm disabling clinkc because it sucks, isnt in portage
36 # and I couldnt care less for upnp
37 econf --enable-rtp \
38 --disable-clinkc \
39 $(use_enable doc) \
40 $(use_enable jingle jingle-p2p) || die "econf failed"
41 # Not yet ported to the new version
42 # $(use_enable msn msnwebcam) \
43 # $(use_enable msn msnavconf) \
44 # $(use_enable yahoo yahoowebcam) \
45 emake || die "emake failed"
48 src_install() {
49 emake install DESTDIR="${D}" || die "emake install failed"
50 dodoc AUTHORS README TODO