updated libiphone
[dottout.git] / dev-python / pigment-python / pigment-python-0.3.5.ebuild
blob8acfc83305190a371d8542dcfe90c9c0131d5606
1 # Copyright 2006-2007 BreakMyGentoo.org
2 # Distributed under the terms of the GNU General Public License v2
4 inherit gnome2 python
6 DESCRIPTION="Python bindings for pigment"
7 HOMEPAGE="http://elisa.fluendo.com/"
8 SRC_URI="http://elisa.fluendo.com/static/download/pigment/${P}.tar.gz"
10 RESTRICT="nomirror"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="-* ~amd64 ~ppc ~x86"
15 IUSE=""
17 RDEPEND=">=media-libs/pigment-0.3.5
18 >=dev-libs/glib-2.8
19 >=dev-python/pygobject-2.8
20 >=media-libs/gstreamer-0.10
21 >=media-libs/gst-plugins-base-0.10
22 >=x11-libs/gtk+-2
23 >=dev-lang/python-2.4"
25 DEPEND="${DEPEND}"
27 DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS README TODO"
29 MAKEOPTS="-j1"
31 src_install() {
32 einstall || die
35 pkg_postinst() {
36 python_version
37 python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
40 pkg_postrm() {
41 python_version
42 python_mod_cleanup