added vloopback-9999
[dottout.git] / media-sound / clementine / clementine-9999.ebuild
blob81f094fdbdc4e7dcb8663fc83ae7547051da511e
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/clementine-0.4.2.ebuild,v 1.2 2010/08/20 11:14:13 ssuominen Exp $
5 EAPI=2
6 inherit cmake-utils gnome2-utils flag-o-matic subversion
8 ESVN_REPO_URI="http://clementine-player.googlecode.com/svn/trunk/"
9 ESVN_PROJECT="clementine"
12 DESCRIPTION="A modern music player and library organizer based on Amarok 1.4 and Qt4"
13 HOMEPAGE="http://code.google.com/p/clementine-player/"
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="gstreamer projectm +xine"
20 COMMON_DEPEND="dev-libs/glib:2
21 dev-libs/libxml2
22 media-libs/liblastfm
23 >=media-libs/taglib-1.6
24 x11-libs/qt-gui:4
25 x11-libs/qt-opengl:4
26 x11-libs/qt-sql:4[sqlite]
27 x11-libs/qt-test:4
28 gstreamer? ( >=media-libs/gstreamer-0.10
29 >=media-libs/gst-plugins-base-0.10
30 projectm? ( media-libs/glew ) )
31 xine? ( media-libs/xine-lib )
32 !gstreamer? ( media-libs/xine-lib )"
33 RDEPEND="${COMMON_DEPEND}
34 gstreamer? ( >=media-plugins/gst-plugins-meta-0.10 )"
35 DEPEND="${COMMON_DEPEND}
36 >=dev-libs/boost-1.39
37 dev-util/pkgconfig"
39 DOCS="Changelog TODO"
41 MAKEOPTS="${MAKEOPTS} -j1"
43 src_unpack() {
44 subversion_src_unpack
45 # AT_M4DIR="m4" eautoreconf
46 # elibtoolize
49 src_prepare() {
50 echo "" > pig.txt
53 src_configure() {
54 append-cppflags "$(pkg-config --cflags-only-I glib-2.0)" #320699
56 mycmakeargs=(
57 "-DENABLE_VISUALISATIONS=OFF"
58 $(cmake-utils_use gstreamer ENGINE_GSTREAMER_ENABLED)
59 "-DENGINE_LIBVLC_ENABLED=OFF"
60 $(cmake-utils_use xine ENGINE_LIBXINE_ENABLED)
61 "-DENGINE_QT_PHONON_ENABLED=OFF"
64 if ! use gstreamer; then
65 mycmakeargs+=(
66 "-DENGINE_LIBXINE_ENABLED=ON"
68 else
69 mycmakeargs+=(
70 $(cmake-utils_use_enable projectm VISUALISATIONS)
74 cmake-utils_src_configure
77 pkg_preinst() {
78 gnome2_icon_savelist
81 pkg_postinst() {
82 if use gstreamer; then
83 ewarn
84 ewarn "If media-plugins/gst-plugins-meta doesn't pull in the plugins you"
85 ewarn "need, you have to install them yourself."
86 ewarn
88 gnome2_icon_cache_update
91 pkg_postrm() {
92 gnome2_icon_cache_update