renamed amuleadu-3.15.ebuild to reflect svn rev
[dottout.git] / net-p2p / amuleadu / amuleadu-3.15-r199.ebuild
blob68a20757553206ee2438bfc60d7d981181154889
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.6.ebuild,v 1.1 2009/09/18 14:59:45 patrick Exp $
5 EAPI="2"
7 inherit subversion autotools eutils flag-o-matic wxwidgets
9 ESVN_REPO_URI="https://amule-adunanza.svn.sourceforge.net/svnroot/amule-adunanza/branches/mrhyde_test"
10 ESVN_REVISION="199"
11 ESVN_PROJECT="amule-adunanza"
12 S="${WORKDIR}/amule-adunanza"
14 DESCRIPTION="aMule AdunanzA, IL software p2p per la comunita' fastweb"
15 HOMEPAGE="http://www.adunanza.net/"
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
20 IUSE="daemon debug geoip gtk nls remote stats unicode upnp"
22 DEPEND="=x11-libs/wxGTK-2.8*
23 dev-libs/crypto++[sse3]
24 >=sys-libs/zlib-1.2.1
25 stats? ( >=media-libs/gd-2.0.26[jpeg] )
26 geoip? ( dev-libs/geoip )
27 upnp? ( >=net-libs/libupnp-1.6.6 )
28 remote? ( >=media-libs/libpng-1.2.0
29 unicode? ( >=media-libs/gd-2.0.26 ) )"
31 pkg_setup() {
32 ewarn ""
33 ewarn "Questo ebuild e' basato su SVN snapshot e sul relativo port"
34 ewarn "sperimentale della patch adunanza. Pertanto e' doppiamente "
35 ewarn "instabile e non vi e' garanzia di corretto funzionamento "
36 ewarn ""
38 if ! use gtk && ! use remote && ! use daemon; then
39 eerror ""
40 eerror "You have to specify at least one of gtk, remote or daemon"
41 eerror "USE flag to build amule."
42 eerror ""
43 die "Invalid USE flag set"
46 if use stats && ! use gtk; then
47 einfo "Note: You would need both the gtk and stats USE flags"
48 einfo "to compile aMule Statistics GUI."
49 einfo "I will now compile console versions only."
53 src_unpack() {
54 subversion_src_unpack
55 AT_M4DIR="m4" eautoreconf
56 elibtoolize
59 pkg_preinst() {
60 if use daemon || use remote; then
61 enewgroup p2p
62 enewuser p2p -1 -1 /home/p2p p2p
66 src_configure() {
67 local myconf
69 WX_GTK_VER="2.8"
71 if use gtk; then
72 einfo "wxGTK with gtk support will be used"
73 need-wxwidgets unicode
74 else
75 einfo "wxGTK without X support will be used"
76 need-wxwidgets base
79 if use gtk ; then
80 use stats && myconf="${myconf}
81 --enable-wxcas
82 --enable-alc"
83 use remote && myconf="${myconf}
84 --enable-amule-gui"
85 else
86 myconf="
87 --disable-monolithic
88 --disable-amule-gui
89 --disable-wxcas
90 --disable-alc"
93 econf \
94 --with-wx-config=${WX_CONFIG} \
95 --with-wxbase-config=${WX_CONFIG} \
96 --enable-amulecmd \
97 $(use_enable debug) \
98 $(use_enable !debug optimize) \
99 $(use_enable daemon amule-daemon) \
100 $(use_enable geoip) \
101 $(use_enable nls) \
102 $(use_enable remote webserver) \
103 $(use_enable stats cas) \
104 $(use_enable stats alcc) \
105 ${myconf} || die
108 src_install() {
109 emake DESTDIR="${D}" install || die
111 if use daemon; then
112 newconfd "${FILESDIR}"/amuled.confd amuled
113 newinitd "${FILESDIR}"/amuled.initd amuled
115 if use remote; then
116 newconfd "${FILESDIR}"/amuleweb.confd amuleweb
117 newinitd "${FILESDIR}"/amuleweb.initd amuleweb
121 pkg_postinst() {
122 ewarn "Per maggiori informazioni sullo sviluppo di aMule AdunanzA"
123 ewarn "e per richieste di supporto potete consultare il forum della"
124 ewarn "comunita': http://forum.adunanza.net"