updated gtkpod
[dottout.git] / net-p2p / amuleadu / amuleadu-3.15_p215.ebuild
blobafe7ba4e9e9ce01b44945fcb7de9c853547c7cbd
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.6.ebuild,v 1.1 2009/09/18 14:59:45 patrick Exp $
5 EAPI="2"
7 inherit subversion autotools eutils flag-o-matic wxwidgets
9 MY_PV="${PV/[0-9.]*\_p}"
11 ESVN_REPO_URI="https://amule-adunanza.svn.sourceforge.net/svnroot/amule-adunanza/branches/mrhyde_test"
12 ESVN_REVISION="${MY_PV}"
13 ESVN_PROJECT="amule-adunanza"
14 S="${WORKDIR}/amule-adunanza"
16 DESCRIPTION="aMule AdunanzA, IL software p2p per la comunita' fastweb"
17 HOMEPAGE="http://www.adunanza.net/"
19 LICENSE="GPL-2"
20 SLOT="0"
21 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
22 IUSE="daemon debug geoip gtk nls remote stats unicode upnp"
24 DEPEND="=x11-libs/wxGTK-2.8*
25 dev-libs/crypto++[sse3]
26 >=sys-libs/zlib-1.2.1
27 stats? ( >=media-libs/gd-2.0.26[jpeg] )
28 geoip? ( dev-libs/geoip )
29 upnp? ( >=net-libs/libupnp-1.6.6 )
30 remote? ( >=media-libs/libpng-1.2.0
31 unicode? ( >=media-libs/gd-2.0.26 ) )"
33 pkg_setup() {
34 ewarn ""
35 ewarn "Questo ebuild e' basato su SVN snapshot e sul relativo port"
36 ewarn "sperimentale della patch adunanza. Pertanto e' doppiamente "
37 ewarn "instabile e non vi e' garanzia di corretto funzionamento "
38 ewarn ""
40 if ! use gtk && ! use remote && ! use daemon; then
41 eerror ""
42 eerror "You have to specify at least one of gtk, remote or daemon"
43 eerror "USE flag to build amule."
44 eerror ""
45 die "Invalid USE flag set"
48 if use stats && ! use gtk; then
49 einfo "Note: You would need both the gtk and stats USE flags"
50 einfo "to compile aMule Statistics GUI."
51 einfo "I will now compile console versions only."
55 src_unpack() {
56 subversion_src_unpack
57 AT_M4DIR="m4" eautoreconf
58 elibtoolize
61 pkg_preinst() {
62 if use daemon || use remote; then
63 enewgroup p2p
64 enewuser p2p -1 -1 /home/p2p p2p
68 src_configure() {
69 local myconf
71 WX_GTK_VER="2.8"
73 if use gtk; then
74 einfo "wxGTK with gtk support will be used"
75 need-wxwidgets unicode
76 else
77 einfo "wxGTK without X support will be used"
78 need-wxwidgets base
81 if use gtk ; then
82 use stats && myconf="${myconf}
83 --enable-wxcas
84 --enable-alc"
85 use remote && myconf="${myconf}
86 --enable-amule-gui"
87 else
88 myconf="
89 --disable-monolithic
90 --disable-amule-gui
91 --disable-wxcas
92 --disable-alc"
95 econf \
96 --with-wx-config=${WX_CONFIG} \
97 --with-wxbase-config=${WX_CONFIG} \
98 --enable-amulecmd \
99 $(use_enable debug) \
100 $(use_enable !debug optimize) \
101 $(use_enable daemon amule-daemon) \
102 $(use_enable geoip) \
103 $(use_enable nls) \
104 $(use_enable remote webserver) \
105 $(use_enable stats cas) \
106 $(use_enable stats alcc) \
107 ${myconf} || die
110 src_install() {
111 emake DESTDIR="${D}" install || die
113 if use daemon; then
114 newconfd "${FILESDIR}"/amuled.confd amuled
115 newinitd "${FILESDIR}"/amuled.initd amuled
117 if use remote; then
118 newconfd "${FILESDIR}"/amuleweb.confd amuleweb
119 newinitd "${FILESDIR}"/amuleweb.initd amuleweb
123 pkg_postinst() {
124 ewarn "Per maggiori informazioni sullo sviluppo di aMule AdunanzA"
125 ewarn "e per richieste di supporto potete consultare il forum della"
126 ewarn "comunita': http://forum.adunanza.net"