updated gtkpod
[dottout.git] / app-pda / gtkpod / gtkpod-9999.ebuild
blob2b8f9c5fc8f907558f5b933cc0f0cb06fa1a9f37
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit git eutils
7 EGIT_REPO_URI="git://gtkpod.git.sourceforge.net/gitroot/gtkpod/gtkpod"
8 EGIT_BOOTSTRAP="./autogen.sh"
10 DESCRIPTION="GUI for iPod using GTK2"
11 HOMEPAGE="http://gtkpod.sourceforge.net"
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
16 IUSE="aac flac gnome hal ogg"
18 DEPEND=">=x11-libs/gtk+-2.6.0
19 >=media-libs/libid3tag-0.15
20 >=gnome-base/libglade-2.4
21 >=gnome-base/libgnomecanvas-2.14
22 >=media-libs/libgpod-0.6.0
23 >=net-misc/curl-7.10
24 gnome? ( >=gnome-base/gnome-vfs-2.6 )
25 hal? ( =sys-apps/hal-0.5* )
26 aac? ( media-libs/libmp4v2 )
27 ogg? ( media-libs/libvorbis )
28 flac? ( media-libs/flac )"
29 RDEPEND="${DEPEND}"
31 pkg_setup() {
32 ewarn "This is a LIVE SVN ebuild."
33 ewarn "That means there are NO promises it will work."
36 src_compile() {
37 econf \
38 $(use_with hal) \
39 $(use_with aac mp4v2) \
40 $(use_with ogg) \
41 $(use_with flac) \
42 $(use_with gnome gnome-vfs ) \
43 || die "econf failed"
44 emake || die "emake failed"
47 src_install() {
48 make install DESTDIR="${D}" || die
49 dodoc README TROUBLESHOOTING