Refreshed debian patches
[conkeror/arlinius.git] / debian / patches / deb-webjumps.diff
blob58cdf36d2bc28a0576388e4c13f050901e54f4bc
1 Adds and enables some Debian and Ubuntu related webjumps which should
2 not be inlcuded in upstream by default.
4 Index: conkeror-0.9.2+git100324/modules/debian/webjumps.js
5 ===================================================================
6 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
7 +++ conkeror-0.9.2+git100324/modules/debian/webjumps.js 2010-03-24 01:17:59.000000000 +0100
8 @@ -0,0 +1,26 @@
9 +/**
10 + * (C) Copyright 2008-2010 Axel Beckert
11 + *
12 + * Use, modification, and distribution are subject to the terms specified in the
13 + * COPYING file.
14 + *
15 + * Webjumps to interact with Debian and Ubuntu websites
16 +**/
18 +require("webjump.js");
20 +// Debian //
21 +define_webjump("debpkg", "http://packages.debian.org/%s");
22 +define_webjump("debfile", "http://packages.debian.org/?searchon=contents&keywords=%s&mode=path&suite=unstable&arch=any");
23 +define_webjump("debbugs", "http://bugs.debian.org/%s");
24 +define_webjump("debpts", "http://packages.qa.debian.org/%s");
25 +define_webjump("debpopcon", "http://qa.debian.org/popcon.php?package=%s");
26 +define_webjump("buildd", "https://buildd.debian.org/%s");
27 +define_webjump("buildd-ports", "http://buildd.debian-ports.org/build.php?pkg=%s");
28 +define_webjump("debqa", "http://qa.debian.org/developer.php?login=%s");
30 +// Ubuntu //
31 +define_webjump("ubuntupkg", "http://packages.ubuntu.com/%s");
32 +define_webjump("ubuntufile", "http://packages.ubuntu.com/search?searchon=contents&keywords=%s&mode=path&arch=any");
33 +define_webjump("ubuntubugs", "http://launchpad.net/ubuntu/+source/%s");
34 +define_webjump("launchpad", "https://launchpad.net/+search?field.text=%s");
35 Index: conkeror-0.9.2+git100324/defaults/preferences/default-modules.js
36 ===================================================================
37 --- conkeror-0.9.2+git100324.orig/defaults/preferences/default-modules.js 2010-03-24 01:15:32.000000000 +0100
38 +++ conkeror-0.9.2+git100324/defaults/preferences/default-modules.js 2010-03-24 01:17:59.000000000 +0100
39 @@ -60,3 +60,6 @@
40 pref("conkeror.load.page-modes/dailymotion", 1);
41 pref("conkeror.load.page-modes/xkcd", 1);
42 pref("conkeror.load.page-modes/stackoverflow", 1);
44 +// Debian modules
45 +pref("conkeror.load.debian/webjumps", 1);