[debian/patches/deb-webjumps.diff] add new default webjump debpopcon
[conkeror/arlinius.git] / debian / patches / deb-webjumps.diff
blob2dc55f27b74943d559dfe34d4c8cee0d24d86c55
1 Adds and enables some Debian and Ubuntu related webjumps which should
2 not be inlcuded in upstream by default.
4 Index: conkeror-0.9.1/modules/debian/webjumps.js
5 ===================================================================
6 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
7 +++ conkeror-0.9.1/modules/debian/webjumps.js 2010-01-13 01:31:38.000000000 +0100
8 @@ -0,0 +1,23 @@
9 +/**
10 + * (C) Copyright 2008-2009 Axel Beckert
11 + *
12 + * Use, modification, and distribution are subject to the terms specified in the
13 + * COPYING file.
14 + *
15 + * Webjumps to interact with Debian and Ubuntu websites
16 +**/
18 +require("webjump.js");
20 +// Debian //
21 +define_webjump("debpkg", "http://packages.debian.org/%s");
22 +define_webjump("debfile", "http://packages.debian.org/?searchon=contents&keywords=%s&mode=path&suite=unstable&arch=any");
23 +define_webjump("debbugs", "http://bugs.debian.org/%s");
24 +define_webjump("debpts", "http://packages.qa.debian.org/%s");
25 +define_webjump("debpopcon", "http://qa.debian.org/popcon.php?package=%s");
27 +// Ubuntu //
28 +define_webjump("ubuntupkg", "http://packages.ubuntu.com/%s");
29 +define_webjump("ubuntufile", "http://packages.ubuntu.com/search?searchon=contents&keywords=%s&mode=path&arch=any");
30 +define_webjump("ubuntubugs", "http://launchpad.net/ubuntu/+source/%s");
31 +define_webjump("launchpad", "https://launchpad.net/+search?field.text=%s");
32 Index: conkeror-0.9.1/defaults/preferences/default-modules.js
33 ===================================================================
34 --- conkeror-0.9.1.orig/defaults/preferences/default-modules.js 2009-09-24 02:17:21.000000000 +0200
35 +++ conkeror-0.9.1/defaults/preferences/default-modules.js 2009-09-24 02:17:48.000000000 +0200
36 @@ -60,3 +60,6 @@
37 pref("conkeror.load.page-modes/dailymotion", 1);
38 pref("conkeror.load.page-modes/gmail", 0);
39 pref("conkeror.load.page-modes/xkcd", 1);
41 +// Debian modules
42 +pref("conkeror.load.debian/webjumps", 1);