Removed the separate server script.
[cnetworkmanager.git] / cnetworkmanager.spec
blob88fb2973c60348e78613bbd2914448c1199f8b67
2 # spec file for package cnetworkmanager (Version 0.8)
4 # Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
20 Name: cnetworkmanager
21 Version: 0.20
22 Release: 1
23 Summary: Command-line client for NetworkManager
24 License: GPL v2 or later
25 Url: http://vidner.net/martin/software/cnetworkmanager/
26 Group: Productivity/Networking/System
27 # build time reqs same as run time because we run tests
28 BuildRequires: dbus-1-python python-gobject2
29 Requires: dbus-1-python python-gobject2
30 Requires: NetworkManager >= 0.7.0
31 Provides: NetworkManager-client
32 BuildRoot: %{_tmppath}/%{name}-%{version}-build
33 BuildArch: noarch
34 Source: %{name}-%{version}.tar.gz
35 %{py_requires}
37 %description
38 Cnetworkmanager is a command-line client for NetworkManager, intended
39 to supplement and replace the GUI applets.
43 %prep
44 %setup
45 #% patch -p1
47 %build
48 python setup.py build
50 %install
51 python setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT --record-rpm=INSTALLED_FILES
52 # mark the /etc files as config
53 sed -i 's,^/etc,%config /etc,' INSTALLED_FILES
55 %check
56 make check-nonm
58 %clean
59 rm -rf %{buildroot}
61 %files -f INSTALLED_FILES
62 %defattr(-,root,root)
63 %doc README COPYING HACKING NEWS
64 %changelog
65 * Sat Mar 21 2009 mvidner@suse.cz
66 - v0.8.4
67 - New: When connecting (-C), monitor the NM connection state.
68 - Fix: RPM packaging: consistent PREFIX (bnc#485413), owning pkgdatadir.
69 - Fix: KeyError with --wep-hex. (James Hogan)
70 - Fix: knetworkmanagerrc: Don't let ConnectionSettings
71 override ConnectionSecrets.
72 - Updated pbkdf2.py to the newest upstream version (license
73 clarified). (Alexander Block)
74 * Fri Mar 06 2009 mvidner@suse.cz
75 - Packaging fix: claim ownership of pkgdatadir
76 * Thu Mar 05 2009 mvidner@suse.cz
77 - v0.8.3
78 - Fix: secrets leak via o.fd.NMS.Connection.Secrets (CVE-2009-0365)
79 - Fix: secrets leak via o.fd.NMS.Connection.GetSettings (bnc#479566#c3)
80 * Sat Nov 22 2008 coolo@suse.de
81 - buildrequire dbus-1 to fix file list check
82 * Tue Nov 18 2008 mvidner@suse.cz
83 - v0.8
84 - New: --wep-pass
85 - New: if there is another applet, report its pid
86 - Fix: do not rely on DBus config from GUI applets
87 * Fri Nov 07 2008 mvidner@suse.cz
88 - initial packaging