Built an RPM using distutils.
[cnetworkmanager.git] / cnetworkmanager.spec
bloba644879bd013445bdf94f86bd0b8d211d7566694
2 # spec file for package cnetworkmanager (Version 0.8)
4 # Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
20 Name: cnetworkmanager
21 Version: 0.20
22 Release: 1
23 Summary: Command-line client for NetworkManager
24 License: GPL v2 or later
25 Url: http://vidner.net/martin/software/cnetworkmanager/
26 Group: Productivity/Networking/System
27 # build time reqs same as run time because we run tests
28 BuildRequires: dbus-1-python python-gobject2
29 Requires: dbus-1-python python-gobject2
30 Provides: NetworkManager-client
31 BuildRoot: %{_tmppath}/%{name}-%{version}-build
32 BuildArch: noarch
33 Source: %{name}-%{version}.tar.gz
34 %{py_requires}
36 %description
37 Cnetworkmanager is a command-line client for NetworkManager, intended
38 to supplement and replace the GUI applets.
42 %prep
43 %setup
44 #% patch -p1
46 %build
47 python setup.py build
49 %install
50 python setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT --record-rpm=INSTALLED_FILES
51 # mark the /etc files as config
52 sed -i 's,^/etc,%config /etc,' INSTALLED_FILES
54 %check
55 make check-nonm
57 %clean
58 rm -rf %{buildroot}
60 %files -f INSTALLED_FILES
61 %defattr(-,root,root)
62 %doc README COPYING HACKING NEWS
63 %changelog
64 * Sat Mar 21 2009 mvidner@suse.cz
65 - v0.8.4
66 - New: When connecting (-C), monitor the NM connection state.
67 - Fix: RPM packaging: consistent PREFIX (bnc#485413), owning pkgdatadir.
68 - Fix: KeyError with --wep-hex. (James Hogan)
69 - Fix: knetworkmanagerrc: Don't let ConnectionSettings
70 override ConnectionSecrets.
71 - Updated pbkdf2.py to the newest upstream version (license
72 clarified). (Alexander Block)
73 * Fri Mar 06 2009 mvidner@suse.cz
74 - Packaging fix: claim ownership of pkgdatadir
75 * Thu Mar 05 2009 mvidner@suse.cz
76 - v0.8.3
77 - Fix: secrets leak via o.fd.NMS.Connection.Secrets (CVE-2009-0365)
78 - Fix: secrets leak via o.fd.NMS.Connection.GetSettings (bnc#479566#c3)
79 * Sat Nov 22 2008 coolo@suse.de
80 - buildrequire dbus-1 to fix file list check
81 * Tue Nov 18 2008 mvidner@suse.cz
82 - v0.8
83 - New: --wep-pass
84 - New: if there is another applet, report its pid
85 - Fix: do not rely on DBus config from GUI applets
86 * Fri Nov 07 2008 mvidner@suse.cz
87 - initial packaging