Updated release scripts to build RPMs with the new spec file
[barry/pauldeden.git] / rpm / barry-bcharge.spec
blob1d667ffca23f2fe2230f635c45ed2f817e6b4977
1 Summary: BlackBerry(tm) Desktop for Linux - bcharge utility
2 Name: barry-bcharge
3 License: GPL
4 Version: 0.7
5 Release: 1
6 Group: Applications/Productivity
7 Source: barry-0.7.tar.gz
8 URL: http://www.netdirect.ca/downloads/barry
9 Vendor: Net Direct Inc.
10 BuildRoot: /var/tmp/%{name}-buildroot
11 Requires: libusb
12 BuildRequires: libusb-devel, gcc-c++
14 %description
15 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
16 is a registered trademark of Research in Motion Limited.)
18 This packages contains the USB charge utility, bcharge. The bcharge utility
19 will adjust the USB port current from 100mA to 500mA when a BlackBerry device
20 is detected. In the case of a newer BlackBerry with USB Mass Storage support,
21 it will also reset the device with the secret handshake to expose the USB
22 interface descriptor that btool will need in order to operate.
24 %prep
26 %setup -n barry-%{version}
28 %build
29 %{__cxx} -Wall -g -o tools/bcharge tools/bcharge.cc -lusb
31 %install
32 %{__mkdir_p} %{buildroot}%{_sbindir}
33 %{__cp} tools/bcharge %{buildroot}%{_sbindir}
34 %{__mkdir_p} %{buildroot}%{_mandir}/man1
35 %{__cp} man/bcharge.1 %{buildroot}%{_mandir}/man1
36 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev/rules.d
37 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d
38 %{__cp} udev/99-barry-perms %{buildroot}%{_sysconfdir}/udev/rules.d
40 %clean
41 %{__rm} -rf %{buildroot}
43 %files
44 %defattr(-,root,root)
45 %doc AUTHORS ChangeLog COPYING NEWS README TODO
46 %attr(0755,root,root) %{_sbindir}/*
47 %attr(0644,root,root) %{_mandir}/man1/*
48 %attr(0644,root,root) %config %{_sysconfdir}/udev/rules.d/*
50 %changelog
51 * Fri Mar 02 2007 Chris Frey <cdfrey@foursquare.net> 0.7-1
52 - bumped version number
53 - removed patch dependency, as patch has been applied
55 * Thu Mar 01 2007 Troy Engel <tengel@users.sourceforge.net> 0.6-1
56 - renamed build RPM to barry-bcharge and enhanced description
57 - reworked spec file to build right out of official releases
58 - use _cxx RPM macro instead of raw g++ to compile
59 - added udev patch to support 0x0006 (Pearl) (sf.net patch #1663986)
60 - added man page, new udev rules and official docs
62 * Mon Feb 19 2007 Troy Engel <tengel@users.sourceforge.net> 0.2-1cvs20070219
63 - build new package with HEAD code and name 0.2 (unofficial)
64 - specfile updates to be more RPM-esque
66 * Sat Jan 06 2007 Troy Engel <tengel@users.sourceforge.net> 0.1-1pearl
67 - apply patches to support productID 0x0006, Pearl