i18n work in progress... desperately needs some housecleaning.
[barry.git] / debian / rules
blob847fbea0661330ade82594a141f7fe23c4ed0945
1 #!/usr/bin/make -f
2 # Based on the multi2 sample debian/rules file:
3 # ---
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
7 #export DH_VERBOSE=1
8 include /usr/share/cdbs/1/rules/debhelper.mk
9 include /usr/share/cdbs/1/class/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
12 # where sources are
13 DEB_SRCDIR = .
14 # in which directory to build
15 DEB_BUILDDIR = .
16 # in which directory to install the sofware
17 DEB_DESTDIR = $(CURDIR)/debian/tmp
18 #To register a debug library package libfoo-dbg for libfoo (which needs unstripped '.so') in compat mode 4:
19 DEB_DH_STRIP_ARGS := --dbg-package=libbarry --dbg-package=libbarry-dev --dbg-package=barry-util --dbg-package=barrybackup-gui --dbg-package=libopensync-plugin-barry
20 #CDBS automatically handles common flags to pass to the configure script,
21 #but it is possible to give some extra parameters :
22 DEB_CONFIGURE_EXTRA_FLAGS := --with-boost=/usr --enable-gui --enable-opensync-plugin
23 COMMON_CONFIGURE_FLAGS := --prefix=/usr
24 DEB_INSTALL_DOCS_ALL =
26 install/barry-util::
27 # Install udev rules for the barry-util package
28 install -d $(CURDIR)/debian/barry-util/etc/udev/rules.d
29 install -m 0644 $(CURDIR)/udev/10-blackberry.rules.Debian $(CURDIR)/debian/barry-util/etc/udev/rules.d/10-blackberry.rules
30 # Install modprobe blacklist file for bcharge, into barry-util package
31 install -d $(CURDIR)/debian/barry-util/etc/modprobe.d
32 install -m 0644 $(CURDIR)/modprobe/blacklist-berry_charge $(CURDIR)/debian/barry-util/etc/modprobe.d/blacklist-berry_charge
34 post-patches::
35 @test -x $(DEB_SRCDIR)/configure && echo "allready autoreconf" || (cd $(DEB_SRCDIR) && autoreconf -i)
37 clean::
38 -@rm -f $(DEB_SRCDIR)/config.guess $(DEB_SRCDIR)/config.sub $(DEB_SRCDIR)/ltmain.sh $(DEB_SRCDIR)/aclocal.m4
39 -@rm -f $(DEB_SRCDIR)/config.h.in $(DEB_SRCDIR)/mkinstalldirs $(DEB_SRCDIR)/install-sh
40 -@rm -f $(DEB_SRCDIR)/missing $(DEB_SRCDIR)/depcomp $(DEB_SRCDIR)/configure $(DEB_SRCDIR)/subdirs
41 -@rm -rf build/ $(DEB_SRCDIR)/configure.files $(DEB_SRCDIR)/stamp-h.in
42 -@rm `find . -type f -name "Makefile.in" -print`