desktop: CalEditDlg: fixed dialog title bar
[barry.git] / rpm / barry.spec
blob9057c7d648cc5be43a2044c53948f2acc99c63fc
1 %dump
3 # enable GUI using: --with gui
4 %define with_gui 0%{?_with_gui:1}
6 # enable opensync 0.2x using: --with opensync
7 %define with_opensync 0%{?_with_opensync:1}
9 # enable opensync 0.4x using: --with opensync4x
10 %define with_opensync4x 0%{?_with_opensync4x:1}
12 # enable desktop using: --with desktop
13 %define with_desktop 0%{?_with_desktop:1}
15 # slight change in udev, fedora 12 and later
16 %if 0%{?fc12} || 0%{?fc13} || 0%{?fc14} || 0%{?fc15}
17 %define use_69_rules 1
18 %else
19 %define use_69_rules 0
20 %endif
23 Summary: BlackBerry(tm) Desktop for Linux
24 Name: barry
25 Version: 0.18.0
26 Release: 0
27 Group: Applications/Productivity
28 License: GPLv2+
29 Source: %{name}-%{version}.tar.bz2
30 URL: http://www.netdirect.ca/software/packages/barry
31 Vendor: Net Direct Inc.
32 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
34 BuildRequires: libusb-devel, gcc-c++, pkgconfig, boost-devel, fuse-devel, zlib-devel
36 %if %{with_gui}
37 BuildRequires: desktop-file-utils
38 %endif
40 # desktop tree
41 %if %{with_desktop}
42 BuildRequires: wxGTK-devel, evolution-data-server-devel
43 %endif
45 %define barryroot %{_builddir}/%{name}-%{version}
47 %description
48 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
49 is a registered trademark of Research in Motion Limited.)
52 %package -n libbarry0
53 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
54 Group: Development/Libraries
55 #Requires: libusb boost
57 %description -n libbarry0
58 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
59 is a registered trademark of Research in Motion Limited.)
61 This package contains the library files, license agreement, README file,
62 and most other assorted documentation common to all sub-packages. You most
63 likely want to also install barry-util and barry-gui.
66 %package -n libbarry-devel
67 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
68 Group: Development/Libraries
69 Requires: libbarry0 boost-devel
71 %description -n libbarry-devel
72 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
73 is a registered trademark of Research in Motion Limited.)
75 This package contains the development library files for Barry, libbarry.
78 %package util
79 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset, bio and others
80 Group: Applications/Productivity
81 Requires: libbarry0 fuse
82 Conflicts: barry-bcharge
84 %description util
85 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
86 is a registered trademark of Research in Motion Limited.)
88 This package contains the commandline tools bcharge, btool, breset, bio and
89 others which will enable you to charge your device with a proper 500mA
90 and be able to access the data on the device in many ways.
93 %if %{with_gui}
94 %package gui
95 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset and others
96 Group: Applications/Productivity
97 Requires: libbarry0
98 BuildRequires: gtkmm24-devel libglademm24-devel libtar-devel
100 %description gui
101 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
102 is a registered trademark of Research in Motion Limited.)
104 This package contains the GUI applications built on top of libbarry.
105 %endif
107 # opensync 0.2x
108 %if %{with_opensync}
109 %package opensync
110 Summary: BlackBerry(tm) Desktop for Linux - opensync plugin
111 Group: Applications/Productivity
112 Requires: libbarry0, libopensync >= 0.22
113 BuildRequires: libopensync-devel
115 %description opensync
116 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
117 is a registered trademark of Research in Motion Limited.)
119 This package contains the opensync plugin.
120 %endif
122 # opensync 0.4x
123 %if %{with_opensync4x}
124 %package opensync4x
125 Summary: BlackBerry(tm) Desktop for Linux - opensync 0.4x plugin
126 Group: Applications/Productivity
127 Requires: libbarry0, libopensync1 >= 0.39
128 BuildRequires: libopensync1-devel
130 %description opensync4x
131 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
132 is a registered trademark of Research in Motion Limited.)
134 This package contains the opensync 0.4x plugin.
135 %endif
137 # desktop tree
138 %if %{with_desktop}
139 %package desktop
140 Summary: BlackBerry(tm) Desktop Panel GUI for Linux
141 Group: Applications/Productivity
142 Requires: libbarry0
143 BuildRequires: wxGTK-devel
145 %description desktop
146 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
147 is a registered trademark of Research in Motion Limited.)
149 This package contains the desktop panel GUI.
150 %endif
152 %prep
153 [ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
154 %setup -q
156 %build
157 # some systems have an rpath checker, and need their own versions of
158 # configure built on the same system in order to pass... in particular,
159 # Fedora 14's 64bit version needs its own configure, for some reason,
160 # in order to recognize that /usr/lib64 is a system path and therefore
161 # there is no reason to use an rpath... unfortunately, configure's
162 # --disable-rpath option seems to have no effect whatsoever. :-(
163 %if "%{?_lib}" == "lib64"
164 ./buildgen.sh cleanall
165 ./buildgen.sh
166 %endif
168 # Generate configure if it does not exist already (for binary-meta)
169 if [ ! -f ./configure ] ; then
170 ./buildgen.sh
173 # setup the environment if there are additions (for binary-meta)
174 export ORIG_PKG_CONFIG_PATH="$PKG_CONFIG_PATH"
175 if [ -n "$ADD_TO_PKG_CONFIG_PATH" ] ; then
176 export PKG_CONFIG_PATH="$ADD_TO_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
180 # main tree
181 %{configure} --enable-boost --enable-nls --with-zlib --with-libusb --enable-rpathhack
182 %{__make} %{?_smp_mflags}
184 # gui tree
185 %if %{with_gui}
186 cd gui/
187 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
188 %{__make} %{?_smp_mflags}
189 cd ../
190 %endif
192 # opensync tree
193 %if %{with_opensync}
194 # if there is a special pkgconfig for opensync 0.2x, use it
195 if [ -n "$OSYNC2X_PKG_CONFIG_PATH" ] ; then
196 export PKG_CONFIG_PATH="$OSYNC2X_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
198 cd opensync-plugin/
199 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
200 %{__make} %{?_smp_mflags}
201 cd ../
202 %endif
204 # opensync4x tree
205 %if %{with_opensync4x}
206 # if there is a special pkgconfig for opensync 0.4x, use it
207 if [ -n "$OSYNC4X_PKG_CONFIG_PATH" ] ; then
208 export PKG_CONFIG_PATH="$OSYNC4X_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
210 cd opensync-plugin-0.4x/
211 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
212 %{__make} %{?_smp_mflags}
213 cd ../
214 %endif
216 # desktop tree
217 %if %{with_desktop}
218 # if there is a special pkgconfig for both opensync 0.4x and 0.2x, use it
219 if [ -n "$OSYNCBOTH_PKG_CONFIG_PATH" ] ; then
220 export PKG_CONFIG_PATH="$OSYNCBOTH_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
222 cd desktop/
223 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack --with-evolution
224 %{__make} %{?_smp_mflags}
225 cd ../
226 %endif
228 %install
229 # main tree
230 %{__make} DESTDIR=%{buildroot} install
231 # delete some test-only programs
232 %{__rm} -f %{buildroot}%{_bindir}/bdptest
233 %{__rm} -f %{buildroot}%{_bindir}/bjvmdebug
234 # delete the .la files
235 %{__rm} -f %{buildroot}%{_libdir}/*.la
236 # proceed as usual...
237 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev/rules.d
238 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
239 %if %{use_69_rules}
240 %{__cp} udev/69-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
241 %else
242 %{__cp} udev/99-blackberry-perms.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
243 %endif
244 %{__mkdir_p} %{buildroot}%{_sysconfdir}/modprobe.d
245 %{__cp} modprobe/blacklist-berry_charge.conf %{buildroot}%{_sysconfdir}/modprobe.d/
246 %{__mkdir_p} %{buildroot}%{_sysconfdir}/ppp/peers
247 %{__cp} ppp/barry-rogers %{buildroot}%{_sysconfdir}/ppp/peers/
248 %{__cp} ppp/barry-minimal %{buildroot}%{_sysconfdir}/ppp/peers/
249 %{__cp} ppp/barry-verizon %{buildroot}%{_sysconfdir}/ppp/peers/
250 %{__cp} ppp/barry-sprint %{buildroot}%{_sysconfdir}/ppp/peers/
251 %{__cp} ppp/barry-telus %{buildroot}%{_sysconfdir}/ppp/peers/
252 %{__cp} ppp/barry-o2ireland %{buildroot}%{_sysconfdir}/ppp/peers/
253 %{__cp} ppp/barry-tmobileus %{buildroot}%{_sysconfdir}/ppp/peers/
254 %{__cp} ppp/barry-att_cingular %{buildroot}%{_sysconfdir}/ppp/peers/
255 %{__cp} ppp/barry-chinamobile %{buildroot}%{_sysconfdir}/ppp/peers/
256 %{__cp} ppp/barry-kpn %{buildroot}%{_sysconfdir}/ppp/peers/
257 %{__cp} ppp/barry-orange-spain %{buildroot}%{_sysconfdir}/ppp/peers/
258 %{__cp} ppp/barry-orangeuk %{buildroot}%{_sysconfdir}/ppp/peers/
259 %{__cp} ppp/barry-mts %{buildroot}%{_sysconfdir}/ppp/peers/
260 %{__cp} ppp/barry-optus-au %{buildroot}%{_sysconfdir}/ppp/peers/
261 %{__cp} ppp/barry-vodafone-au %{buildroot}%{_sysconfdir}/ppp/peers/
262 %{__mkdir_p} %{buildroot}%{_sysconfdir}/chatscripts
263 %{__cp} ppp/barry-rogers.chat %{buildroot}%{_sysconfdir}/chatscripts/
264 %{__cp} ppp/barry-minimal.chat %{buildroot}%{_sysconfdir}/chatscripts/
265 %{__cp} ppp/barry-verizon.chat %{buildroot}%{_sysconfdir}/chatscripts/
266 %{__cp} ppp/barry-sprint.chat %{buildroot}%{_sysconfdir}/chatscripts/
267 %{__cp} ppp/barry-telus.chat %{buildroot}%{_sysconfdir}/chatscripts/
268 %{__cp} ppp/barry-o2ireland.chat %{buildroot}%{_sysconfdir}/chatscripts/
269 %{__cp} ppp/barry-tmobileus.chat %{buildroot}%{_sysconfdir}/chatscripts/
270 %{__cp} ppp/barry-att_cingular.chat %{buildroot}%{_sysconfdir}/chatscripts/
271 %{__cp} ppp/barry-chinamobile.chat %{buildroot}%{_sysconfdir}/chatscripts/
272 %{__cp} ppp/barry-kpn.chat %{buildroot}%{_sysconfdir}/chatscripts/
273 %{__cp} ppp/barry-orange-spain.chat %{buildroot}%{_sysconfdir}/chatscripts/
274 %{__cp} ppp/barry-orangeuk.chat %{buildroot}%{_sysconfdir}/chatscripts/
275 %{__cp} ppp/barry-mts.chat %{buildroot}%{_sysconfdir}/chatscripts/
276 %{__cp} ppp/barry-optus-au.chat %{buildroot}%{_sysconfdir}/chatscripts/
277 %{__cp} ppp/barry-vodafone-au.chat %{buildroot}%{_sysconfdir}/chatscripts/
278 # Install hal fdi config
279 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
280 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
281 %{__cp} hal/fdi/information/10freedesktop/10-blackberry.fdi %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
282 %{__cp} hal/fdi/policy/10osvendor/19-blackberry-acl.fdi %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
283 # Install hal support script
284 %{__mkdir_p} %{buildroot}%{_bindir}
285 %{__cp} hal/hal-blackberry %{buildroot}%{_bindir}
286 # Install bash completion scripts
287 %{__mkdir_p} %{buildroot}%{_sysconfdir}/bash_completion.d
288 %{__cp} bash/bjavaloader %{buildroot}%{_sysconfdir}/bash_completion.d
289 %{__cp} bash/btool %{buildroot}%{_sysconfdir}/bash_completion.d
291 # gui tree
292 %if %{with_gui}
293 cd gui/
294 %{__make} DESTDIR=%{buildroot} install
295 # Install barry logo icon
296 cd ../
297 %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
298 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps
299 desktop-file-install --vendor netdirect \
300 --dir %{buildroot}%{_datadir}/applications \
301 menu/barrybackup.desktop
302 %endif
304 # opensync tree
305 %if %{with_opensync}
306 cd opensync-plugin/
307 %{__make} DESTDIR=%{buildroot} install
308 # remove .la files
309 %{__rm} -f %{buildroot}%{_libdir}/opensync/plugins/*.la
310 cd ../
311 %endif
313 # opensync4x tree
314 %if %{with_opensync4x}
315 cd opensync-plugin-0.4x/
316 %{__make} DESTDIR=%{buildroot} install
317 # remove .la files
318 %{__rm} -f %{buildroot}%{_libdir}/libopensync1/plugins/*.la
319 cd ../
320 %endif
322 # desktop tree
323 %if %{with_desktop}
324 cd desktop/
325 %{__make} DESTDIR=%{buildroot} install
326 # remove .la files
327 %{__rm} -f %{buildroot}%{_libdir}/*.la
328 cd ../
329 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps/barry_desktop_icon.png
330 desktop-file-install --vendor netdirect \
331 --dir %{buildroot}%{_datadir}/applications \
332 menu/barrydesktop.desktop
333 %endif
335 %files -n libbarry0
336 %defattr(-,root,root)
337 %attr(-,root,root) %{_libdir}/libbarry.so.*
338 %attr(-,root,root) %{_libdir}/libbarrydp.so.*
339 %attr(-,root,root) %{_libdir}/libbarryjdwp.so.*
340 %attr(-,root,root) %{_libdir}/libbarrysync.so.*
341 %attr(-,root,root) %{_libdir}/libbarrybackup.so.*
342 %attr(-,root,root) %{_libdir}/libbarryalx.so.*
343 %doc AUTHORS ChangeLog COPYING NEWS README
345 %files -n libbarry-devel
346 %defattr(-,root,root)
347 %attr(0644,root,root) %{_includedir}/barry*/barry/*
348 %attr(0644,root,root) %{_libdir}/libbarry.a
349 %attr(0644,root,root) %{_libdir}/libbarry.so
350 %attr(0644,root,root) %{_libdir}/libbarrydp.a
351 %attr(0644,root,root) %{_libdir}/libbarrydp.so
352 %attr(0644,root,root) %{_libdir}/libbarryjdwp.a
353 %attr(0644,root,root) %{_libdir}/libbarryjdwp.so
354 %attr(0644,root,root) %{_libdir}/libbarrysync.a
355 %attr(0644,root,root) %{_libdir}/libbarrysync.so
356 %attr(0644,root,root) %{_libdir}/libbarrybackup.a
357 %attr(0644,root,root) %{_libdir}/libbarrybackup.so
358 %attr(0644,root,root) %{_libdir}/libbarryalx.a
359 %attr(0644,root,root) %{_libdir}/libbarryalx.so
360 %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
361 %doc COPYING TODO doc/* examples/*.cc
363 %files util
364 %defattr(-,root,root)
365 %attr(0755,root,root) %{_sbindir}/bcharge
366 %attr(0755,root,root) %{_sbindir}/breset
367 %attr(0755,root,root) %{_sbindir}/pppob
368 %attr(0755,root,root) %{_bindir}/btool
369 %attr(0755,root,root) %{_bindir}/bwatch
370 %attr(0755,root,root) %{_bindir}/bio
371 %attr(0755,root,root) %{_bindir}/btardump
372 %attr(0755,root,root) %{_bindir}/btarcmp
373 %attr(0755,root,root) %{_bindir}/bfuse
374 %attr(0755,root,root) %{_bindir}/bjavaloader
375 %attr(0755,root,root) %{_bindir}/balxparse
376 %attr(0755,root,root) %{_bindir}/bjdwp
377 %attr(0755,root,root) %{_bindir}/brawchannel
378 %attr(0755,root,root) %{_bindir}/bs11nread
379 %attr(0755,root,root) %{_bindir}/bidentify
380 %attr(0755,root,root) %{_bindir}/brecsum
381 %attr(0755,root,root) %{_bindir}/upldif
382 %attr(0755,root,root) %{_bindir}/hal-blackberry
383 %attr(0644,root,root) %{_mandir}/man1/btool*
384 %attr(0644,root,root) %{_mandir}/man1/bwatch*
385 %attr(0644,root,root) %{_mandir}/man1/bio*
386 %attr(0644,root,root) %{_mandir}/man1/btardump*
387 %attr(0644,root,root) %{_mandir}/man1/btarcmp*
388 %attr(0644,root,root) %{_mandir}/man1/bfuse*
389 %attr(0644,root,root) %{_mandir}/man1/bjavaloader*
390 %attr(0644,root,root) %{_mandir}/man1/balxparse*
391 %attr(0644,root,root) %{_mandir}/man1/bjdwp*
392 %attr(0644,root,root) %{_mandir}/man1/brawchannel*
393 %attr(0644,root,root) %{_mandir}/man1/bs11nread*
394 %attr(0644,root,root) %{_mandir}/man1/bidentify*
395 %attr(0644,root,root) %{_mandir}/man1/bcharge*
396 %attr(0644,root,root) %{_mandir}/man1/pppob*
397 %attr(0644,root,root) %{_mandir}/man1/brecsum*
398 %attr(0644,root,root) %{_mandir}/man1/breset*
399 %attr(0644,root,root) %{_mandir}/man1/upldif*
400 %attr(0644,root,root) %{_datadir}/locale/*
401 %attr(0644,root,root) %{_datadir}/hal/fdi/information/10freedesktop/10-blackberry.fdi
402 %attr(0644,root,root) %{_datadir}/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi
403 %attr(0644,root,root) %config %{_sysconfdir}/udev/rules.d/*
404 %attr(0644,root,root) %config %{_sysconfdir}/modprobe.d/blacklist-berry_charge.conf
405 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-rogers
406 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-minimal
407 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-verizon
408 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-sprint
409 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-telus
410 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-o2ireland
411 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-tmobileus
412 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-att_cingular
413 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-chinamobile
414 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-kpn
415 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-orange-spain
416 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-orangeuk
417 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-mts
418 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-optus-au
419 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-vodafone-au
420 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-rogers.chat
421 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-minimal.chat
422 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-verizon.chat
423 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-sprint.chat
424 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-telus.chat
425 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-o2ireland.chat
426 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-tmobileus.chat
427 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-att_cingular.chat
428 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-chinamobile.chat
429 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-kpn.chat
430 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-orange-spain.chat
431 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-orangeuk.chat
432 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-mts.chat
433 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-optus-au.chat
434 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-vodafone-au.chat
435 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/bjavaloader
436 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/btool
437 %doc COPYING
438 %doc zsh
439 %doc ppp/README
441 %if %{with_gui}
442 %files gui
443 %defattr(-,root,root)
444 %attr(0755,root,root) %{_bindir}/barrybackup
445 %attr(0644,root,root) %{_datadir}/barry/glade/*.glade
446 %attr(0644,root,root) %{_datadir}/pixmaps/barry_logo_icon.png
447 %attr(0644,root,root) %{_datadir}/applications/*barrybackup.desktop
448 %attr(0644,root,root) %{_mandir}/man1/barrybackup*
449 %doc COPYING
450 %endif
452 %if %{with_opensync}
453 %files opensync
454 %defattr(-,root,root)
455 %attr(0755,root,root) %{_libdir}/opensync/plugins/barry_sync.so
456 %attr(0644,root,root) %{_datadir}/opensync/defaults/barry-sync
457 %doc COPYING
458 %endif
460 %if %{with_opensync4x}
461 %files opensync4x
462 %defattr(-,root,root)
463 %attr(0755,root,root) %{_libdir}/libopensync1/plugins/barry_sync.so
464 %attr(0644,root,root) %{_datadir}/libopensync1/defaults/barry-sync
465 %doc COPYING
466 %endif
468 # desktop tree
469 %if %{with_desktop}
470 %files desktop
471 %defattr(-,root,root)
472 %attr(0755,root,root) %{_bindir}/barrydesktop
473 %attr(0755,root,root) %{_bindir}/bsyncjail
474 %attr(0755,root,root) %{_bindir}/blistevo
475 %attr(0755,root,root) %{_bindir}/bsynccl
476 %attr(0644,root,root) %{_datadir}/barry/desktop/0.22/*
477 %attr(0644,root,root) %{_datadir}/barry/desktop/0.40/*
478 %attr(0644,root,root) %{_datadir}/barry/desktop/images/*.png
479 %attr(0644,root,root) %{_datadir}/pixmaps/barry_desktop_icon.png
480 %attr(0644,root,root) %{_datadir}/applications/*barrydesktop.desktop
481 %attr(0644,root,root) %{_mandir}/man1/barrydesktop*
482 %attr(-,root,root) %{_libdir}/libosyncwrap.so.*
483 %attr(-,root,root) %{_libdir}/libosyncwrap.a
484 %attr(-,root,root) %{_libdir}/libosyncwrap.so
485 %attr(0644,root,root) %{_includedir}/barry*/osyncwrap/*
486 %doc COPYING
487 %endif
489 %clean
490 [ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
491 [ "%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
493 %post -n libbarry0
494 /sbin/ldconfig
496 %postun -n libbarry0
497 /sbin/ldconfig
499 %changelog
500 * Mon Aug 31 2011 Chris Frey <cdfrey@foursquare.net> 0.18.0-0
501 - version bump
502 - removed dependency of libbarry-devel on libusb(-devel)
503 - added osyncwrap headers
504 - removed opensuse special cases
505 - back to optional --with behaviour
506 - added opensync 0.4x package support
507 - removed .la files
508 - split up dev libraries a little better (-devel should have the dev libs)
509 - put desktop library in desktop package
510 - added orangeuk and mts ppp chatscript files
511 - added bwatch
512 - added code to clean the buildroot at start
513 - added evolution dependencies for desktop build
514 - removed libopensync dependency from barry-desktop (can be either, both, or none)
515 - renamed 0.4x plugin dependency to libopensync1
516 - removed extraneous library dependencies, which should be handled automatically
517 - added btarcmp
518 - removed brimtrans, bktrans, and btranslate (devel tools)
520 * Fri May 28 2010 Chris Frey <cdfrey@foursquare.net> 0.17.0-0
521 - version bump
522 - added NLS support
523 - cleaned up conditionals
524 - added Fedora 13 support
525 - added new ppp chat scripts for Orange Spain, Optus and Vodafone AU
526 - added copy of barry-sprint as barry-telus
527 - added brawchannel, btardump, bio, and balxparse
528 - added desktop support
529 - cleaned up desktop variables
531 * Sat Sep 29 2009 Chris Frey <cdfrey@foursquare.net> 0.16-0
532 - version bump
533 - added new ppp chat script for KPN Nederland
534 - using new udev rules set
535 - added bjdwp and manpage, and removed some test-only programs
536 - added bash and zsh completion scripts
537 - added .desktop file and icon for barrybackup
539 * Fri Apr 10 2009 Chris Frey <cdfrey@foursquare.net> 0.15-0
540 - version bump
541 - added HAL FDI scripts
542 - added bjavaloader and bfuse
543 - updated for udev directory reorganization in Barry source tree
544 - added zlib-devel to BuildRequires list
545 - added brimtrans
547 * Wed Sep 24 2008 Chris Frey <cdfrey@foursquare.net> 0.14-0
548 - version bump
549 - added new ppp chat script for T-Mobile US
550 - renamed libbarry to libbarry0
552 * Thu May 29 2008 Chris Frey <cdfrey@foursquare.net> 0.13-1
553 - version bump
554 - added brecsum
555 - added ppp options and chat scripts
556 - added manpages for pppob, brecsum, breset, upldif, barrybackup
557 - spec file now assumes gui and opensync, with conditional checks depending on host
559 * Fri Dec 07 2007 Chris Frey <cdfrey@foursquare.net> 0.12-1
560 - version bump
562 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.11-1
563 - version bump
565 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.10-1
566 - version bump
567 - removed ktrans and translate from rpm package
568 - added bidentify
570 * Thu Aug 09 2007 Chris Frey <cdfrey@foursquare.net> 0.9-1
571 - version bump
573 * Fri Aug 03 2007 Chris Frey <cdfrey@foursquare.net> 0.8-1
574 - version bump
575 - changed tarball to bz2
577 * Tue May 01 2007 Chris Frey <cdfrey@foursquare.net> 0.7-2
578 - added pppob to utils
580 * Thu Mar 08 2007 Chris Frey <cdfrey@foursquare.net> 0.7-1
581 - removed barry base package that only contained docs, and put docs in libbarry*
582 - changed barrybackup reference to barry-gui
583 - removed the patch step, as version 0.7 shouldn't need it
584 - added license file to each package
586 * Sun Mar 04 2007 Troy Engel <tengel@users.sourceforge.net> 0.6-1
587 - initial build
588 - adding udev and console perms patch for raw 0.6