debian: fixed dependency on ppp for kfreebsd (Closes: #678233)
[barry.git] / debian / control
blobb4c796e532e4627af2c1e7523633a80823b53716
2 # Ideally, the evolution source path autodetection routines would
3 # load libebook and libecal dynamically, so that dependencies would
4 # not force the inclusion of evolution-data-server and friends.
6 # But there are two problems with that, which need to be
7 # cracked first:
9 #     - the glib major version numbers, according to the .so
10 #       files, are not consistent between distros
11 #     - when used dynamically, in a program that is not otherwise
12 #       linked to glib, it can segfault... and it seems to get
13 #       funky somewhere inside glib itself... so I'm guessing that
14 #       the library is not being initialized properly :-(
16 # All this means that general compilations of barrydesktop will
17 # need evolution-data-server and friends linked in.  It is possible
18 # to compile without by supplying --without-evolution on the configure
19 # command line, but then you risk getting a weak auto-detection
20 # of data sources in newer versions of evolution.  If your data
21 # sources are located in paths like this:
23 #      file:///home/cdfrey/.evolution/addressbook/local/system
25 # then it is safe to disable evolution for the barrydesktop compile.
27 # Otherwise, if your version of evolution is new, and uses funkier names,
28 # or uses local:system, or puts its files under ~/.config, then
29 # build --with-evolution and link against it.
31 Source: barry
32 Section: misc
33 Priority: optional
34 Maintainer: Chris Frey <cdfrey@foursquare.net>
35 Build-Depends: debhelper (>= 7.0.0), g++ (>= 4.1), cdbs, autoconf, autoconf-archive, automake, libtool, pkg-config, libusb-dev, libboost-serialization-dev, libxml++2.6-dev, libfuse-dev (>= 2.5), zlib1g-dev, libtar-dev, libglibmm-2.4-dev, libgtkmm-2.4-dev, libglademm-2.4-dev, autopoint | gettext (<< 0.18), libgcal-dev, wx-common, libwxgtk2.8-dev, libsdl-dev, evolution-data-server-dev, libebook1.2-dev, libedata-book1.2-dev, libedata-cal1.2-dev, libedataserver1.2-dev
36 Standards-Version: 3.9.3
37 Homepage: http://netdirect.ca/barry
38 Vcs-Git: git://repo.or.cz/barry.git
39 Vcs-Browser: http://repo.or.cz/w/barry.git
41 Package: libbarry18
42 Section: libs
43 Architecture: any
44 Depends: ${shlibs:Depends}, ${misc:Depends}
45 Description: Library for using the BlackBerry handheld on Linux
46  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
47  .
48  This package contains shared libraries for low level USB communication,
49  backup file writing and parsing, sync support routines such as vcard
50  support, JDWP debugging support, and ALX release file parsing.
52 Package: libbarry18-dbg
53 Section: debug
54 Priority: extra
55 Architecture: any
56 Depends: libbarry18 (= ${binary:Version}), ${misc:Depends}
57 Description: Library for using the BlackBerry handheld (debug symbols)
58  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
59  .
60  This package contains the debug versions of the shared libraries found
61  in the libbarry package.
63 Package: libbarry-dev
64 Section: libdevel
65 Architecture: any
66 Depends: libbarry18 (= ${binary:Version}), ${misc:Depends}
67 Description: Development files for libbarry
68  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
69  .
70  This package contains the header files required for building applications
71  based on libbarry.
73 Package: barry-util
74 Section: utils
75 Architecture: any
76 Depends: libbarry18, udev [linux-any], python, ${shlibs:Depends}, ${misc:Depends}
77 Suggests: ppp [linux-any]
78 Description: Command line utilities for working with the RIM BlackBerry Handheld
79  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
80  .
81  This package contains command line utilities, such as bcharge, btool,
82  breset, bio, etc.  It also contains udev rules to automate USB charging
83  as soon as devices are plugged in.
85 Package: barry-util-dbg
86 Section: debug
87 Priority: extra
88 Architecture: any
89 Depends: barry-util (= ${binary:Version}), ${misc:Depends}
90 Description: Command line BlackBerry utilities (debug symbols)
91  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
92  .
93  This package contains the debug versions of the command line utilities
94  from the barry-util package.
96 Package: barrybackup-gui
97 Section: utils
98 Architecture: any
99 Depends: libbarry18, ${shlibs:Depends}, ${misc:Depends}
100 Description: GTK+ GUI for backing up the RIM BlackBerry Handheld
101  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
103  This package contains a GUI application for making backups and restores.
104  It supports configurations to select individual device databases, or to
105  restore only certain databases from out of a backup file.  It supports
106  multiple devices plugged in at the same time.
108 Package: barrybackup-gui-dbg
109 Section: debug
110 Priority: extra
111 Architecture: any
112 Depends: barrybackup-gui (= ${binary:Version}), ${misc:Depends}
113 Description: GTK+ GUI for backing up BlackBerry (debug symbols)
114  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
116  This package contains the debug version of the backup GUI from the
117  barrybackup-gui package.
119 Package: barrydesktop
120 Section: utils
121 Architecture: any
122 Depends: libbarry18, barry-util, xterm, ${shlibs:Depends}, ${misc:Depends}
123 Recommends: barrybackup-gui, ppp [linux-any]
124 Suggests: gksu
125 Description: Desktop Panel GUI for the RIM BlackBerry Handheld
126  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
128  This package contains the top level Barry Desktop GUI management
129  application for backups, syncing with OpenSync 0.2x and 0.4x, modem
130  operation, device data migration, and desktop editing of database
131  records via the GUI (Address Book, Calendar, Tasks, Memos).
133 Package: barrydesktop-dbg
134 Section: debug
135 Priority: extra
136 Architecture: any
137 Depends: barrydesktop (= ${binary:Version}), ${misc:Depends}
138 Description: Desktop Panel GUI for the RIM BlackBerry Handheld (debug symbols)
139  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
141  This package contains the debug files for the Barry desktop found in the
142  barrydesktop package.
144 #Package: barry-doc
145 #Architecture: all
146 #Description: Documentation for barry
147 # Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
148 # It comes with a command line tool for exploring the device and for making quick
149 # backups. The goal of this project is to create a fully functional syncing
150 # mechanism on Linux.