Tarball tree for barry-0.17.0.tar.bz2
[barry.git] / debian / barry-util.postinst
blobd29f1b6c040aae484a48d1503bcccadd65c86e92
1 #!/bin/sh -e
3 everything() {
4 # set ownership for ppp options files
5 for f in /etc/ppp/peers/barry-*
6 do
7 chown root:dip "$f"
8 done
10 # set permissions for chatscripts
11 for f in /etc/chatscripts/barry-*.chat
13 chown root:dip "$f"
14 chmod 0640 "$f"
15 done
18 case "$1" in
19 configure)
20 everything
23 abort-upgrade|abort-remove|abort-deconfigure)
27 echo "postinst called with unknown argument '$1'" >&2
28 exit 1
30 esac
32 #DEBHELPER#
34 exit 0