debian: disabled evolution dependency in Desktop
[barry.git] / debian / rules
blob1d787e4a1d1b6be50cd4e3e4f0e63bdfab47dbb2
1 #!/usr/bin/make -f
2 # Based on the multi2 sample debian/rules file:
3 # ---
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
7 #export DH_VERBOSE=1
8 include /usr/share/cdbs/1/rules/debhelper.mk
9 include /usr/share/cdbs/1/class/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
12 # The following is for systems that support hardened builds.
13 # Not all systems have this support, so make it conditional on buildflags.mk
14 ifneq ($(strip $(wildcard /usr/share/dpkg/buildflags.mk)),)
15 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
16 export DEB_CFLAGS_MAINT_APPEND = -Wall
17 include /usr/share/dpkg/buildflags.mk
18 endif
20 # where sources are
21 DEB_SRCDIR = .
23 # in which directory to build
24 DEB_BUILDDIR = .
26 # in which directory to install the sofware
27 DEB_DESTDIR = $(CURDIR)/debian/tmp
29 #CDBS automatically handles common flags to pass to the configure script,
30 #but it is possible to give some extra parameters :
31 DEB_CONFIGURE_EXTRA_FLAGS := --enable-boost --enable-nls --with-zlib --enable-gui --enable-desktop --with-guisu=/usr/bin/gksu $(BARRY_CONFIGURE_OPTS) --with-libusb --enable-rpathhack --without-evolution
32 COMMON_CONFIGURE_FLAGS := --prefix=/usr
33 DEB_INSTALL_DOCS_ALL =
35 install/barry-util::
36 ifeq ($(DEB_HOST_ARCH_OS), linux)
37 # Install udev rules for the barry-util package
38 install -d $(CURDIR)/debian/barry-util/lib/udev/rules.d
39 install -m 0644 \
40 $(DEB_SRCDIR)/udev/10-blackberry.rules \
41 $(DEB_SRCDIR)/udev/99-blackberry-perms.rules \
42 $(CURDIR)/debian/barry-util/lib/udev/rules.d
43 endif
44 # Install modprobe blacklist file for bcharge, into barry-util package
45 install -d $(CURDIR)/debian/barry-util/etc/modprobe.d
46 install -m 0644 $(DEB_SRCDIR)/modprobe/blacklist-berry_charge.conf $(CURDIR)/debian/barry-util/etc/modprobe.d/blacklist-berry_charge.conf
47 # Install default ppp options and chat scripts
48 install -d $(CURDIR)/debian/barry-util/etc/ppp/peers
49 install -m 0644 \
50 $(DEB_SRCDIR)/ppp/barry-rogers \
51 $(DEB_SRCDIR)/ppp/barry-minimal \
52 $(DEB_SRCDIR)/ppp/barry-verizon \
53 $(DEB_SRCDIR)/ppp/barry-sprint \
54 $(DEB_SRCDIR)/ppp/barry-telus \
55 $(DEB_SRCDIR)/ppp/barry-o2ireland \
56 $(DEB_SRCDIR)/ppp/barry-emobile \
57 $(DEB_SRCDIR)/ppp/barry-tmobileus \
58 $(DEB_SRCDIR)/ppp/barry-att_cingular \
59 $(DEB_SRCDIR)/ppp/barry-chinamobile \
60 $(DEB_SRCDIR)/ppp/barry-kpn \
61 $(DEB_SRCDIR)/ppp/barry-orange-spain \
62 $(DEB_SRCDIR)/ppp/barry-orangeuk \
63 $(DEB_SRCDIR)/ppp/barry-mts \
64 $(DEB_SRCDIR)/ppp/barry-optus-au \
65 $(DEB_SRCDIR)/ppp/barry-vodafone-au \
66 $(CURDIR)/debian/barry-util/etc/ppp/peers
67 install -d $(CURDIR)/debian/barry-util/etc/chatscripts
68 install -m 0640 \
69 $(DEB_SRCDIR)/ppp/barry-rogers.chat \
70 $(DEB_SRCDIR)/ppp/barry-minimal.chat \
71 $(DEB_SRCDIR)/ppp/barry-verizon.chat \
72 $(DEB_SRCDIR)/ppp/barry-sprint.chat \
73 $(DEB_SRCDIR)/ppp/barry-telus.chat \
74 $(DEB_SRCDIR)/ppp/barry-o2ireland.chat \
75 $(DEB_SRCDIR)/ppp/barry-emobile.chat \
76 $(DEB_SRCDIR)/ppp/barry-tmobileus.chat \
77 $(DEB_SRCDIR)/ppp/barry-att_cingular.chat \
78 $(DEB_SRCDIR)/ppp/barry-chinamobile.chat \
79 $(DEB_SRCDIR)/ppp/barry-kpn.chat \
80 $(DEB_SRCDIR)/ppp/barry-orange-spain.chat \
81 $(DEB_SRCDIR)/ppp/barry-orangeuk.chat \
82 $(DEB_SRCDIR)/ppp/barry-mts.chat \
83 $(DEB_SRCDIR)/ppp/barry-optus-au.chat \
84 $(DEB_SRCDIR)/ppp/barry-vodafone-au.chat \
85 $(CURDIR)/debian/barry-util/etc/chatscripts
86 # Install hal fdi configs
87 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
88 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
89 install -m 0644 $(DEB_SRCDIR)/hal/fdi/information/10freedesktop/10-blackberry.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
90 install -m 0644 $(DEB_SRCDIR)/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
91 # Install hal support script
92 install -d $(CURDIR)/debian/barry-util/usr/lib/barry
93 install -m 0755 $(DEB_SRCDIR)/hal/hal-blackberry $(CURDIR)/debian/barry-util/usr/lib/barry
94 # Install bash and zsh completion scripts
95 install -d $(CURDIR)/debian/barry-util/etc/bash_completion.d
96 install -m 0644 \
97 $(DEB_SRCDIR)/bash/bjavaloader \
98 $(DEB_SRCDIR)/bash/btool \
99 $(CURDIR)/debian/barry-util/etc/bash_completion.d
100 # Install examples/ into libbarry-dev
101 install -d $(CURDIR)/debian/libbarry-dev/usr/share/doc/libbarry-dev/examples
102 install -m 0644 $(DEB_SRCDIR)/examples/*.cc \
103 $(CURDIR)/debian/libbarry-dev/usr/share/doc/libbarry-dev/examples
105 install/barrybackup-gui::
106 # Install barry icon
107 install -d $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
108 install -m 0644 $(DEB_SRCDIR)/logo/barry_logo_debian_menu_icon.xpm $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps/barry_backup_menu_icon.xpm
109 # Install Gnome .desktop file
110 install -d $(CURDIR)/debian/barrybackup-gui/usr/share/applications
111 install -m 0644 $(DEB_SRCDIR)/menu/barrybackup.desktop $(CURDIR)/debian/barrybackup-gui/usr/share/applications
113 install/barrydesktop::
114 # Install barry icon
115 install -d $(CURDIR)/debian/barrydesktop/usr/share/pixmaps
116 install -m 0644 $(DEB_SRCDIR)/logo/barry_logo_debian_menu_icon.xpm $(CURDIR)/debian/barrydesktop/usr/share/pixmaps/barry_desktop_menu_icon.xpm
117 # Install Gnome .desktop file
118 install -d $(CURDIR)/debian/barrydesktop/usr/share/applications
119 install -m 0644 $(DEB_SRCDIR)/menu/barrydesktop.desktop $(CURDIR)/debian/barrydesktop/usr/share/applications
121 install/barry-doc::
122 # Build the static version of the docs
123 cp -a $(DEB_SRCDIR)/doc/www $(CURDIR)/debian
124 cd $(CURDIR)/debian/www && ./static.sh
125 # Install to share/doc
126 install -d $(CURDIR)/debian/barry-doc/usr/share/doc/barry-doc/www
127 install -m 0644 $(CURDIR)/debian/www/*.html $(CURDIR)/debian/www/*.png $(CURDIR)/debian/www/*.css $(CURDIR)/debian/barry-doc/usr/share/doc/barry-doc/www
129 post-patches::
130 @rm -f $(CURDIR)/deb_srcdir
131 @ln -s $(DEB_SRCDIR) $(CURDIR)/deb_srcdir
132 @test -x $(DEB_SRCDIR)/configure && echo "allready autoreconf" || (cd $(DEB_SRCDIR) && autoreconf -i)
134 os22-binary::
135 # DEB_SRCDIR can be relative, so change into directory to use pwd.
137 # Note: that the compiler flags below depend on opensync-plugin's
138 # debian/rules having a DESTDIR target of opensync-plugin/debian/tmp
139 (cd $(DEB_SRCDIR) && \
140 export TREE_BUILD_CXXFLAGS="-I`pwd`/opensync-plugin/debian/tmp/usr/include/barry18" && \
141 export TREE_BUILD_LDFLAGS="-L`pwd`/opensync-plugin/debian/tmp/usr/lib" && \
142 export PKG_CONFIG_PATH="`pwd`:$(PKG_CONFIG_PATH)" && \
143 export LD_LIBRARY_PATH="`pwd`/opensync-plugin/debian/tmp/usr/lib:$(LD_LIBRARY_PATH)" && \
144 cd opensync-plugin && \
145 debian/rules TREE_BUILD_DIR="`pwd`/.." binary)
147 os22-clean::
148 (cd $(DEB_SRCDIR)/opensync-plugin && debian/rules clean)
150 os4x-binary::
151 # DEB_SRCDIR can be relative, so change into directory to use pwd.
153 # Note: that the compiler flags below depend on opensync-plugin-0.4x's
154 # debian/rules having a DESTDIR target of opensync-plugin-0.4x/debian/tmp
155 (cd $(DEB_SRCDIR) && \
156 export TREE_BUILD_CXXFLAGS="-I`pwd`/opensync-plugin-0.4x/debian/tmp/usr/include/barry18" && \
157 export TREE_BUILD_LDFLAGS="-L`pwd`/opensync-plugin-0.4x/debian/tmp/usr/lib" && \
158 export PKG_CONFIG_PATH="`pwd`:$(PKG_CONFIG_PATH)" && \
159 export LD_LIBRARY_PATH="`pwd`/opensync-plugin-0.4x/debian/tmp/usr/lib:$(LD_LIBRARY_PATH)" && \
160 cd opensync-plugin-0.4x && \
161 debian/rules TREE_BUILD_DIR="`pwd`/.." binary)
163 os4x-clean::
164 (cd $(DEB_SRCDIR)/opensync-plugin-0.4x && debian/rules clean)
166 clean::
167 -@rm -f $(CURDIR)/deb_srcdir