cleanup text-match
[awl.git] / debian / rules
blob482c469d32649159121bce0aa772d7d44d642c28
1 #!/usr/bin/make -f
3 # rules for AWL
5 # This file allows you to build any of the binary packages independantly, via binary-<package> targets.
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
10 # This has to be exported to make some magic below work.
11 export DH_OPTIONS
13 build: build-arch build-indep
14 build-arch: build-stamp
15 build-indep: build-stamp
16 build-stamp:
17 dh_testdir
18 $(MAKE)
19 touch build-stamp
21 clean:
22 dh_testdir
23 dh_testroot
24 rm -f build-stamp
26 $(MAKE) clean
27 -rm -f build
29 dh_clean
31 install: DH_OPTIONS=
32 install: build
33 dh_testdir
34 dh_testroot
35 dh_prep
36 dh_installdirs
38 dh_install
40 # This single target is used to build all the packages, all at once, or
41 # one at a time. So keep in mind: any options passed to commands here will
42 # affect _all_ packages. Anything you want to only affect one package
43 # should be put in another target, such as the install target.
44 binary-common:
45 dh_testdir
46 dh_testroot
47 dh_installchangelogs
48 dh_installdocs
49 # dh_installexamples
50 # dh_installmenu
51 # dh_installdebconf
52 # dh_installlogrotate
53 # dh_installemacsen
54 # dh_installcatalogs
55 # dh_installpam
56 # dh_installmime
57 # dh_installinit
58 # dh_installman
59 # dh_installcron
60 # dh_installinfo
61 # dh_installwm
62 # dh_installudev
63 # dh_lintian
64 # dh_undocumented
65 # dh_strip
66 # dh_link
67 dh_compress --exclude=.js
68 dh_fixperms
69 # dh_perl
70 # dh_python
71 # dh_makeshlibs
72 dh_installdeb
73 # dh_shlibdeps
74 dh_gencontrol
75 dh_md5sums
76 dh_builddeb
78 # Build architecture independant packages using the common target.
79 binary-indep: build install
80 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
82 # Build architecture dependant packages using the common target.
83 binary-arch: build install
85 # Any other binary targets build just one binary package at a time.
86 binary-%: build install
87 make -f debian/rules binary-common DH_OPTIONS=-p$*
89 binary: binary-indep binary-arch
91 .PHONY: build clean binary-indep binary-arch binary-common binary install