configure fixes, N900 fixes
[awish.git] / debian / rules
bloba0c599072a204f07215ea0d61ba227f6aaa6fb7f
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19 DESTDIR = $(CURDIR)/debian/awish-bld
20 #CFLAGS = -Wall -g
22 #ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 # CFLAGS += -O0
24 #else
25 # CFLAGS += -O2
26 #endif
29 ifneq (,$(findstring sound,$(DEB_BUILD_OPTIONS)))
30 FORCE_SOUND = --force-sound
31 else
32 FORCE_SOUND =
33 endif
35 ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
36 GNU89INLINE = MAEMO47=1 USE_THUMB=1
37 PROF =
38 else
39 ifneq (,$(findstring k8maemo47,$(DEB_BUILD_OPTIONS)))
40 GNU89INLINE = MAEMO47=1
41 PROF =
42 else
43 GNU89INLINE =
44 PROF = PROFILE=noopt
45 endif
46 endif
48 configure: configure-stamp
49 configure-stamp:
50 dh_testdir
51 jam configure --prefix=/usr --install-awasm --install-vmsrc $(FORCE_SOUND)
52 touch $@
55 build: build-stamp
56 build-stamp: configure-stamp
57 dh_testdir
58 # Add here commands to configure the package.
59 jam -a $(GNU89INLINE) $(PROF)
60 touch $@
63 clean:
64 dh_testdir
65 dh_testroot
66 rm -f configure-stamp build-stamp
68 # Add here commands to clean up after the build process.
69 rm -f build-stamp configure-stamp || true
70 jam distclean
71 rm -rf $(DESTDIR) || true
72 rm -rf $(CURDIR)/debian/awish || true
73 rm -rf $(CURDIR)/debian/awish-data || true
74 rm -rf $(CURDIR)/debian/awish-vm-source || true
76 dh_clean
78 install: build
79 dh_testdir
80 dh_testroot
81 dh_clean -k
82 dh_installdirs
84 # Add here commands to install the package into $(DESTDIR)
85 DESTDIR=$(DESTDIR) jam install
88 # Build architecture-independent files here.
89 binary-indep: build install
90 # We have nothing to do by default.
92 # Build architecture-dependent files here.
93 binary-arch: build install
94 dh_testdir
95 dh_testroot
96 dh_installchangelogs
97 # dh_installdocs
98 # dh_installexamples
99 dh_install
100 # dh_installmenu
101 # dh_installdebconf
102 # dh_installlogrotate
103 # dh_installemacsen
104 # dh_installpam
105 # dh_installmime
106 # dh_python
107 # dh_installinit
108 # dh_installcron
109 # dh_installinfo
110 # dh_installman
111 dh_link
112 dh_strip
113 dh_compress
114 dh_fixperms
115 # dh_perl
116 # dh_makeshlibs
117 dh_installdeb
118 dh_shlibdeps
119 dh_gencontrol
120 # maemo-optify
121 dh_md5sums
122 dh_builddeb
124 binary: binary-indep binary-arch
125 .PHONY: build clean binary-indep binary-arch binary install