Fixed bug with not stop properly by adding mainlockfile
[autosshd_ALT.git] / autosshd.spec
blob0273dcd8244ed4c7cc9ff0aef65e19bfff0035e0
1 # vim: set ft=spec : -*- rpm-spec -*-
2 %define autossh_user _autossh
3 %define autossh_group _autossh
4 %define autossh_dir /var/lib/autosshd
6 Name: autosshd
7 Version: 0.0.3
8 Release: alt9
10 Summary: System administration - AutoSSH system level service
12 Group: System/Servers
13 License: GPL
14 Url: http://wiki.etersoft.ru/Autosshd
16 Packager: Danil Mikhailov <danil@altlinux.org>
18 #Source-git: https://github.com/vitlav/autosshd
19 Source: %name-%version.tar
21 BuildArch: noarch
23 BuildPreReq: rpm-build-intro
25 Requires: shadow-utils openssh-common
26 Requires: autossh
28 %description
29 Run autossh as system service at startup.
31 %prep
32 %setup
34 %install
35 mkdir -p %buildroot%_sysconfdir/autossh.d/
37 mkdir -p %buildroot%_runtimedir/%name/
38 mkdir -p %buildroot%_locksubsysdir/%name/
39 mkdir -p %buildroot/%_tmpfilesdir/
41 cat <<EOF >%buildroot/%_tmpfilesdir/%name.conf
42 d %_runtimedir/%name 0755 %autossh_user %autossh_group
43 d %_locksubsysdir/%name 0755 root root
44 EOF
46 mkdir -p %buildroot/%autossh_dir/.ssh/
47 #echo "StrictHostKeyChecking no" > %buildroot%autossh_dir/.ssh/config
49 mkdir -p %buildroot%_docdir/%name/
51 install -D -m754 etc/rc.d/init.d/autosshd %buildroot%_initdir/%name
52 # TODO: we need automate filling of this config
53 install -D -m644 etc/sysconfig/autosshd %buildroot%_sysconfigdir/%name
55 install -m644 etc/autossh.d/*.conf.template %buildroot%_sysconfdir/autossh.d/
57 mkdir -p %buildroot%_datadir/%name/
58 mkdir -p %buildroot%_bindir/
59 mkdir -p %buildroot/lib/systemd/system/
60 cp usr/bin/autosshd-ssh %buildroot%_bindir/
61 cp share/autossh-conf %buildroot%_datadir/%name/
62 cp share/autosshd.setup* %buildroot%_datadir/%name/
63 cp lib/systemd/system/autosshd.service %buildroot/lib/systemd/system/autosshd.service
65 %pre
66 # Add the "_autossh" user
67 %_sbindir/groupadd -r -f %autossh_group 2>/dev/null ||:
68 %_sbindir/useradd -M -r -g %autossh_group -c 'Autossh daemon' \
69 -s /dev/null -d %autossh_dir %autossh_user 2>/dev/null ||:
71 %post
72 %post_service %name
74 %preun
75 %preun_service %name
77 %files
78 %doc doc/*
79 %attr(750,%autossh_user,%autossh_group) %dir %autossh_dir/
80 %config(noreplace) %attr(750,%autossh_user,%autossh_group) %autossh_dir/.ssh/
81 %config(noreplace) %_sysconfigdir/%name
82 %_sysconfdir/autossh.d/
83 %_initdir/%name
84 %_tmpfilesdir/%name.conf
85 %attr(750,%autossh_user,%autossh_group) %dir %_runtimedir/%name/
86 %dir %_locksubsysdir/%name/
87 %dir %_datadir/%name/
88 %_datadir/%name/autossh-conf
89 %_datadir/%name/autosshd.setup
90 %_datadir/%name/autosshd.setup.user
91 %_bindir/autosshd-ssh
92 /lib/systemd/system/autosshd.service
94 %changelog
95 * Wed Sep 30 2015 Danil Mikhailov <danil@altlinux.org> 0.0.3-alt9
96 - Added initial realisation of systemd init service
97 - Change runlevel to 60
98 - Added 400 permission as allowed
100 * Mon Dec 29 2014 Danil Mikhailov <danil@altlinux.org> 0.0.3-alt8
101 - fixed test sudo autosshd-ssh anyssh.ru
103 * Wed Dec 17 2014 Vitaly Lipatov <lav@altlinux.ru> 0.0.3-alt7
104 - small fixes
106 * Thu Nov 27 2014 Danil Mikhailov <danil@altlinux.org> 0.0.3-alt6
107 - Cleanup git log
109 * Thu Sep 18 2014 Danil Mikhailov <danil@altlinux.org> 0.0.3-alt5
110 - Correct manual in config files
112 * Wed Sep 17 2014 Danil Mikhailov <danil@altlinux.org> 0.0.3-alt4
113 - added cheking for existing config
115 * Wed Sep 17 2014 Danil Mikhailov <danil@altlinux.org> 0.0.3-alt3
116 - move files in right directory
117 - fix start when already running
119 * Thu Sep 11 2014 Danil Mikhailov <danil@altlinux.org> 0.0.3-alt2
120 - rewrite doc
121 - rewrite init script
122 - added new scripts:
123 - autosshd-conf for export variables to _anyssh user
124 - autosshd-ssh for test connection over ssh
126 * Mon Jul 07 2014 Vitaly Lipatov <lav@altlinux.ru> 0.0.3-alt1
127 - development release
128 - rewrite init script
129 - add anyssh.ru.conf.example
130 - add unused generate key script
131 - cleanup spec, move initialize code to a separate script
133 * Sat Jan 11 2014 Ivan Zakharyaschev <imz@altlinux.org> 0.0.2-alt8
134 - doc: Added links to some guides (how to make use of autosshd).
136 * Fri Jan 10 2014 Ivan Zakharyaschev <imz@altlinux.org> 0.0.2-alt7
137 - Declare lav@ as the maintainer
139 * Sat Dec 28 2013 Ivan Zakharyaschev <imz@altlinux.org> 0.0.2-alt6
140 - Handle /var/lock/subsys/* and /var/run/* in tmpfiles.d
141 (otherwise they used to be gone from the tmpfs after a reboot)
143 * Sat Dec 28 2013 Ivan Zakharyaschev <imz@altlinux.org> 0.0.2-alt5
144 - Fix user deletion after an upgrade according to http://www.altlinux.org/PseudoUserPolicy
146 * Sat Dec 28 2013 Ivan Zakharyaschev <imz@altlinux.org> 0.0.2-alt4
147 - Correct wrong paths in scripts, configs, and examples.
149 * Tue Nov 19 2013 Vitaly Lipatov <lav@altlinux.ru> 0.0.2-alt3
150 - initial build to ALT Linux Sisyphus
152 * Tue Oct 08 2013 Vitaly Lipatov <lav@altlinux.ru> 0.0.2-alt2
153 - cleanup spec
155 * Mon Apr 09 2012 Dmitriy Kruglikov <dkr@altlinux.org> 0.0.2-alt1
156 - Code rewritten to work with multiple connections
158 * Thu Apr 05 2012 Dmitriy Kruglikov <dkr@altlinux.org> 0.0.1-alt4
159 - Fixed bugs in postinstall and postuninstal scripts
161 * Tue Apr 03 2012 Dmitriy Kruglikov <dkr@altlinux.org> 0.0.1-alt3
162 - Fixes
164 * Tue Apr 03 2012 Dmitriy Kruglikov <dkr@altlinux.org> 0.0.1-alt2
165 - Ready for testing
167 * Mon Apr 02 2012 Dmitriy Kruglikov <dkr@altlinux.org> 0.0.1-alt1
168 - Initial draft