Initial commit: Uploaded everything from abs/core
[arch-rock.git] / support / sudo / PKGBUILD
blob78e6cebaf39a587835cf213e5da99734664343b4
1 # $Id: PKGBUILD,v 1.37 2007/12/31 04:45:03 paul Exp $
2 # Maintainer: Paul Mattal <paul@archlinux.org>
3 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
4 pkgname=sudo
5 pkgver=1.6.9p10
6 pkgrel=3
7 pkgdesc="Give certain users the ability to run some commands as root"
8 arch=(i686 x86_64)
9 url="http://www.sudo.ws/sudo/"
10 # 2 separate licenses apply, custom and ISC, each covering part of the software
11 license=('custom' 'ISC')
12 depends=('glibc' 'pam')
13 backup=('etc/sudoers' 'etc/pam.d/sudo')
14 source=(ftp://ftp.sudo.ws/pub/sudo/$pkgname-$pkgver.tar.gz sudo.pam)
15 options=('!libtool')
16 md5sums=('16db2a1213159a1fac8239eab58108f5'
17          '4e7ad4ec8f2fe6a40e12bcb2c0b256e3')
19 build() {
20   cd $startdir/src/$pkgname-$pkgver || return 1
22   ./configure --prefix=/usr --with-pam --libexecdir=/usr/lib \
23     --with-editor=/usr/bin/vi --with-all-insults --with-logfac=auth || return 1
24   make || return 1
25   make DESTDIR=$startdir/pkg install || return 1
26   install -D -m644 $startdir/src/sudo.pam $startdir/pkg/etc/pam.d/sudo \
27         || return 1
29   #install the license
30   install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/sudo/LICENSE \
31         || return 1