Initial commit: Uploaded everything from abs/core
[arch-rock.git] / support / ipw3945d / PKGBUILD
blobca05e8d24cdc295cb8c576cfefe6be4979fb0676
1 # $Id: PKGBUILD,v 1.13 2007/11/15 23:53:16 daniel Exp $
2 # Maintainer: James Rayner <iphitus@gmail.com>
3 # Contributor: Giovanni Scafora <linuxmania@gmail.com>
5 pkgname=ipw3945d
6 pkgver=1.7.22
7 pkgrel=4
8 pkgdesc="Regulatory daemon for IPW3945"
9 arch=(i686 x86_64)
10 url="http://www.bughost.org/ipw3945"
11 license=""
12 depends=('glibc')
13 install=ipw3945d.install
14 source=(http://www.bughost.org/ipw3945/daemon/$pkgname-$pkgver.tgz ipw3945d.rc)
16 build() {
17   cd $startdir/src/$pkgname-$pkgver
18   #Install daemon w/ Arch specific fix
19   if [ "$CARCH" = "x86_64" ]; then
20   install -D -m 755 x86_64/ipw3945d $startdir/pkg/sbin/ipw3945d
21   else install -D -m 755 x86/ipw3945d $startdir/pkg/sbin/ipw3945d
22   fi
23   # Install license
24   install -D -m 644 LICENSE.ipw3945d $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
25   install -m755 -D $startdir/src/ipw3945d.rc $startdir/pkg/etc/rc.d/ipw3945d || return 
28 md5sums=('097888f5be05eb2b9b87dcdbeeb948ce' '72aafd7cba214592de6175974a48b4f9')