Initial commit: Uploaded everything from abs/core
[arch-rock.git] / base / module-init-tools / PKGBUILD
blobe823fbbd2b881fc03f1241a5d97995ebc2a651c4
1 # $Id: PKGBUILD,v 1.19 2007/11/16 00:02:35 daniel Exp $
2 # Maintainer: judd <jvinet@zeroflux.org>
3 pkgname=module-init-tools
4 pkgver=3.2.2
5 pkgrel=5
6 pkgdesc="Utilities for inserting and removing modules from the Linux kernel"
7 arch=(i686 x86_64)
8 url="http://www.kernel.org"
9 license=('GPL')
10 groups=('base')
11 depends=('glibc')
12 conflicts=('modutils')
13 replaces=('modutils')
14 backup=('etc/modprobe.conf' 'etc/modules.conf' 'etc/modprobe.devfs')
15 source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2 \
16         makefile.patch modprobe.conf)
17 md5sums=('a1ad0a09d3231673f70d631f3f5040e9' '47e14fda7a46668290d11d0444d81826'\
18          '6db59d41e04941a790f80c1a4432faef')
20 build() {
21   cd $startdir/src/$pkgname-$pkgver
22   patch -Np1 -i ../makefile.patch || return 1
23   sed -i 's|/usr/bin/install|/bin/install|g' install-with-care
24   ./configure --prefix=/usr --exec-prefix=/
25   make || return 1
26   INSTALL=/bin/install make DESTDIR=$startdir/pkg install
27   install -D -m644 ../modprobe.conf $startdir/pkg/etc/modprobe.conf