Initial commit: Uploaded everything from abs/core
[arch-rock.git] / base / lilo / PKGBUILD
blob7dcff6711d0f1b16e75a3a2a7b3e13836a6640c4
1 # $Id: PKGBUILD,v 1.62 2007/11/15 23:53:18 daniel Exp $
2 # Maintainer: judd <jvinet@zeroflux.org>
3 pkgname=lilo
4 pkgver=22.8
5 pkgrel=2
6 pkgdesc="A bootloader for Linux"
7 arch=(i686 x86_64)
8 url="http://lilo.go.dyndns.org"
9 license=('BSD')
10 # While lilo should stay in the base category,
11 # it usually makes no sense if it is installed
12 # with pacman -S base, therefore, don't add
13 # the base group here.
14 #groups=('base')
15 backup=(etc/lilo.conf)
16 depends=(device-mapper coreutils)
17 makedepends=(bin86)
18 install=lilo.install
19 source=(http://home.san.rr.com/johninsd/pub/linux/lilo/lilo-$pkgver.src.tar.gz lilo.conf)
20 md5sums=('72765f2aafd20e23ecf07ebd22baeec7' 'a3a4c90bead3f9b8672bd384ff9f8db1')
22 build() {
23   cd $startdir/src/$pkgname-$pkgver
24   make || return 1
25   make ROOT=$startdir/pkg MAN_DIR=/usr/man install
26   mkdir -p $startdir/pkg/etc
27   cp $startdir/$pkgname.conf $startdir/pkg/etc/
28   # install license
29   install -D -m644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/license.txt