archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ocaml-bigarray-compat / trunk / PKGBUILD
blobe98eef7976acb792f67a9ff6e0d85ea92a0123f9
1 # Maintainer: Konstantin Gizdov <arch at kge dot pw>
2 _pkgname='bigarray-compat'
3 pkgname="ocaml-${_pkgname}"
4 pkgver=1.1.0
5 pkgrel=1
6 pkgdesc="Compatibility library to use Stdlib.Bigarray when possible"
7 arch=(x86_64)
8 url="https://github.com/mirage/bigarray-compat"
9 license=('Apache')
10 depends=("ocaml")
11 makedepends=("ocaml-compiler-libs" "dune")
12 source=("https://github.com/mirage/${pkgname#ocaml-}/archive/refs/tags/v${pkgver}.tar.gz")
13 sha512sums=('bbd9c2b319930db832ae8d41844ef81e74ced9f745f32981f2efcc9777220d55e1e5d6dc2965e9e1a6ed5e0d56ad27c672289f8dc28fbe2658f3230cbda5a800')
15 build() {
16     cd "${srcdir}/${_pkgname}-${pkgver}"
17     dune build -p $_pkgname
20 package() {
21     cd "${srcdir}/${_pkgname}-${pkgver}"
22     DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "/usr/lib/ocaml"
24     install -dm755 "${pkgdir}/usr/share/"
25     mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"