archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libcuckoo / trunk / PKGBUILD
blob16313683b80b23e6301739e5a58c7e1664e392e6
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: chn <g897331845@gmail.com>
4 pkgname=libcuckoo
5 pkgver=0.3.1
6 pkgrel=1
7 pkgdesc="A high-performance, concurrent hash table"
8 arch=('any')
9 url='https://github.com/efficient/libcuckoo'
10 license=('Apache')
11 makedepends=('cmake')
12 source=(${pkgname}-${pkgver}.tar.gz::https://github.com/efficient/libcuckoo/archive/refs/tags/v${pkgver}.tar.gz)
13 sha256sums=('a87122b963ef6b7eadca3e41cb4b533f3b6ad9b588ab2f2140eb6ab0db9a7ba8')
15 build() {
16     mkdir build
17     cd build
18     cmake ../${pkgname}-${pkgver} \
19       -DCMAKE_BUILD_TYPE='None' \
20       -DCMAKE_INSTALL_PREFIX='/usr' \
21       -DBUILD_TESTS=1 \
22       -DBUILD_STRESS_TESTS=1 \
23       -DBUILD_UNIT_TESTS=1
24     make
27 check() {
28   cd build
29   ctest
32 package() {
33     cd build
34     make DESTDIR="$pkgdir" install