archrelease: copy trunk to community-staging-x86_64
[arch-community.git] / podofo / repos / community-staging-x86_64 / PKGBUILD.svn
blob807d486699441f23f873f4847bc9d2079bbd9e3f
1 # $Id: PKGBUILD 213059 2017-02-18 11:53:46Z arojas $
2 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
3 # Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
4 # Contributor: Preecha Patumchareonpol <yumyai at gmail.com> 
6 pkgname=podofo
7 pkgver=0.9.5.svn.20170807
8 pkgrel=1
9 pkgdesc='Library to work with the PDF file format'
10 url='http://podofo.sourceforge.net'
11 arch=('x86_64')
12 license=('GPL')
13 makedepends=('cmake' 'subversion')
14 depends=('lua' 'openssl' 'fontconfig' 'libtiff' 'libidn' 'libjpeg-turbo')
15 source=('svn+https://svn.code.sf.net/p/podofo/code/podofo/trunk')
16 sha256sums=('SKIP')
18 prepare() {
19         cd "${srcdir}/trunk"
20         install -d build
23 build() {
24         cd "${srcdir}/trunk/build"
25         cmake -DCMAKE_INSTALL_PREFIX=/usr .. \
26                 -DFREETYPE_INCLUDE_DIR=/usr/include/freetype2 \
27                 -DPODOFO_BUILD_SHARED=1 \
28                 -DPODOFO_HAVE_JPEG_LIB=1 \
29                 -DPODOFO_HAVE_PNG_LIB=1 \
30                 -DPODOFO_HAVE_TIFF_LIB=1
31         make
34 package() {
35         cd "${srcdir}/trunk/build"
36         make DESTDIR=$pkgdir install