archrelease: copy trunk to community-any
[arch-community.git] / perl-scope-guard / trunk / PKGBUILD
blobf6760314dbdb4eef67b408285ac9f713fc5cfe25
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-scope-guard
4 pkgver=0.21
5 pkgrel=5
6 pkgdesc="Lexically-scoped resource management"
7 arch=('any')
8 license=('PerlArtistic')
9 url="https://metacpan.org/release/Scope-Guard"
10 depends=('perl')
11 options=('!emptydirs')
12 source=("https://cpan.metacpan.org/authors/id/C/CH/CHOCOLATE/Scope-Guard-$pkgver.tar.gz")
13 sha512sums=('65492e08ab79dc323649166e83ffc13c6f1fffaa9c60d581d8854dfe427a54a3c3c5e4d8b90308d4b1a31a1a54c7977b4e1d36fc9005c6e716c2361ce187fc9f')
15 build() {
16   cd Scope-Guard-$pkgver
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd Scope-Guard-$pkgver
23   make test
26 package() {
27   cd Scope-Guard-$pkgver
28   make DESTDIR="$pkgdir" install