Revert "debug; set -x to config"
[aiccu.git] / rpm / aiccu.spec
blob417e6ec926b8fcdfd574b9803c046974d0e42c1a
1 ############################################################
2 # AICCU - Automatic IPv6 Connectivity Client Utility
3 # by Jeroen Massar <jeroen@sixxs.net>
4 # (c) Copyright 2003-2005 SixXS
5 ############################################################
6 # AICCU RPM Spec File
7 ############################################################
9 Summary: AICCU - SixXS Automatic IPv6 Connectivity Client Utility
10 Name: aiccu
11 Version: 2007.01.15
12 Release: 1%{?dist}
13 License: BSD
14 Group: System Environment/Daemons
15 URL: http://www.sixxs.net/tools/aiccu/
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 Source: http://www.sixxs.net/archive/sixxs/aiccu/unix/aiccu_%{version}.tar.gz
18 BuildRequires: gnutls-devel
19 Requires: iproute
20 Requires(post): chkconfig
21 Requires(preun): chkconfig, initscripts
22 Requires(postun): initscripts
24 %description
25 This client automatically gives one IPv6 connectivity
26 without having to manually configure interfaces etc.
27 One does need a SixXS account and at least a tunnel. These
28 can be freely & gratis requested from the SixXS website.
29 For more information about SixXS check http://www.sixxs.net
31 %prep
32 %setup -q -n %{name}
33 # fix executable permissions on non-executable content
34 # so debuginfo can pick them up properly
35 find . -type f -not -name rules -and -not -name *init* -exec chmod a-x \{\} \;
37 %build
38 make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 mkdir -p $RPM_BUILD_ROOT
43 make install DESTDIR=$RPM_BUILD_ROOT
45 %post
46 if [ "$1" = "1" ]; then
47 /sbin/chkconfig --add aiccu
50 %preun
51 if [ "$1" = "0" ]; then
52 /sbin/service aiccu stop >/dev/null 2>&1
53 /sbin/chkconfig --del aiccu
56 %postun
57 /sbin/service aiccu condrestart > /dev/null 2>&1 || :
59 %clean
60 make clean
61 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
63 %files
64 %defattr(-,root,root)
65 %doc doc/README doc/LICENSE
66 %{_sbindir}/aiccu
67 # aiccu.conf contains the users's SixXS password, so don't
68 # make it readable by non-root
69 %attr(600, root,root) %config(noreplace) %{_sysconfdir}/aiccu.conf
70 %{_sysconfdir}/init.d/aiccu
73 %changelog
74 * Wed Jun 28 2006 Matt Domsch <matt@domsch.com> 2005.01.31-4
75 - export CFLAGS properly, fix permissions on files for debuginfo
77 * Wed Jun 28 2006 Matt Domsch <matt@domsch.com> 2005.01.31-3
78 - cleanups per Fedora Extras review
80 * Sat Apr 22 2006 Matt Domsch <matt@domsch.com> 2005.01.31-2
81 - match Fedora Extras spec guidelines
82 - add postun condrestart
83 - add reload initscript arg to satisfy rpmlint
85 * Sun Aug 29 2004 Jeroen Massar <jeroen@sixxs.net> 2004.08.29
86 - Beta2 with TIC, 6in4, 6in4-heartbeat and AYIYA support