Strip plugins on make install
[MonkeyD.git] / monkey.spec
blobf63a362ba6f8c5eed35c9a56b95ef6af446fd8f3
1 %define branch 0.11
2 %define webroot /var/www/monkey
3 %define prefix /usr
4 %define bindir /usr/bin
5 %define sysconf /etc/monkey
6 %define logdir /var/log/monkey
7 %define plugdir /usr/lib/monkey
9 Summary: Monkey is a Fast and Lightweight Web Server for Linux
10 Name: monkey
11 Version: 0.11.0
12 Packager: Eduardo Silva <edsiper@gmail.com>
13 Release: 1%{dist}
14 License: GPL
15 Group: System Environment/Daemons
16 Source: http://www.monkey-project.com/releases/%{branch}/%{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 URL: http://www.monkey-project.com
20 %description
21 Monkey is a really fast and lightweight Web Server for Linux. It has been
22 designed to be very scalable with low memory and CPU consumption, the perfect
23 solution for embedded and high production environments.
25 %prep
26 %setup
27 %build
28 export CFLAGS=$RPM_OPT_FLAGS
29 ./configure \
30 --prefix=%{prefix} \
31 --bindir=%{bindir} \
32 --sysconfdir=%{sysconf} \
33 --datadir=%{webroot} \
34 --logdir=%{logdir} \
35 --plugdir=%{plugdir}
37 make
39 %pre
40 /usr/sbin/useradd -s /sbin/nologin -M -r -d %{webroot} \
41 -c "Monkey HTTP Daemon" monkey &>/dev/null ||:
43 %post
44 sed -i 's/User nobody/User monkey/g' /etc/monkey/monkey.conf
46 %install
47 rm -rf %{buildroot}
48 install -d %{buildroot}/usr/share/doc
49 install -d %{buildroot}%{logdir}
51 make DESTDIR=%{buildroot} install
53 %clean
54 rm -rf %{buildroot}
56 %files
57 %defattr(-,root,root)
58 %doc README LICENSE ChangeLog*
59 %attr(644,root,root) %{_sysconfdir}/monkey/*
60 %{_bindir}/*
61 %{_libdir}/*
62 %{_datadir}/*
63 %{webroot}/*
64 %{logdir}
65 %defattr(-, monkey, monkey, 0750)
66 %{_localstatedir}/log/monkey
68 %changelog
69 * Thu Jul 08 2010 Eduardo Silva <edsiper at, gmail.com> 0.11.0-1
70 - Initial rpm package for Fedora 13