Set mk_pointer config->port and add server port to Palm plugin
[MonkeyD.git] / monkey.spec
blob9545f808b8815b46cee4d470b3222f15a252372f
1 Name: monkey
2 Version: 0.11.0
3 Release: 2%{?dist}
4 Summary: A fast and lightweight web server for Linux
5 Group: System Environment/Daemons
6 License: GPLv2+
7 URL: http://www.monkey-project.com
8 Source: http://www.monkey-project.com/releases/0.11/%{name}-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11 BuildRequires: gettext
12 Requires(pre): shadow-utils
14 %description
15 Monkey is a fast and lightweight web server for Linux. It has been
16 designed to be very scalable with low memory and CPU consumption, the
17 perfect solution for embedded and high production environments.
19 %prep
20 %setup -q
22 %build
23 export CFLAGS=%{optflags}
24 ./configure \
25 --prefix=%{_prefix} \
26 --bindir=%{_bindir} \
27 --sysconfdir=%{_sysconf}/%{name} \
28 --datadir=%{_var}/www/%{name} \
29 --logdir=%{_var}/log/%{name} \
30 --plugdir=%{_libexecdir}/%{name}
32 make %{?_smp_mflags}
34 %install
35 rm -rf %{buildroot}
36 install -d %{buildroot}%{_var}/log/%{name}
38 make install DESTDIR=%{buildroot}
40 %{__sed} -i 's/User nobody/User monkey/g' \
41 %{buildroot}%{_sysconf}/%{name}/monkey.conf
43 %find_lang %{name}
45 %clean
46 rm -rf %{buildroot}
48 %pre
49 getent group monkey > /dev/null || groupadd -r monkey
50 getent passwd monkey > /dev/null || \
51 useradd -r -g monkey -d %{webroot} -s /sbin/nologin \
52 -c "Monkey HTTP Daemon" monkey
53 exit 0
55 %files -f %{name}.lang
56 %defattr(-,root,root)
57 %doc README LICENSE ChangeLog*
58 %attr(644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/monkey.conf
59 %attr(644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/monkey.mime
60 %attr(644,root,root) %{_sysconfdir}/%{name}/plugins
61 %attr(644,root,root) %{_sysconfdir}/%{name}/sites
62 %{_bindir}/banana
63 %{_bindir}/monkey
64 %dir %{_var}/www/%{name}
65 %attr(0750, monkey, monkey) %ghost %{_localstatedir}/log/%{name}
67 %changelog
68 * Thu Jul 22 2010 Horst H. von Brand <vonbrand@inf.utfsm.cl> - 0.11.0-2
69 - First cut at cleaning up specfile according to Fedora guidelines
71 * Thu Jul 08 2010 Eduardo Silva <edsiper at gmail.com> 0.11.0-1
72 - Initial rpm package for Fedora 13