Move nuc-pri to nuc-pek
[myCabin.git] / shell-hook.nix
blobd08ad1d70f24b831c42dce6a3c311c4c8b4c04f6
1 # Copyright (c) 2018, Jack J. Mao
2 # All rights reserved.
3 # Use of this source code is governed by a BSD-style
4 # license that can be found in the LICENSE file.
6 { pkgs
7 , lib
8 , ...
9 }:
10 with builtins;
11 let
13   inherit (lib)
14     makeBinPath
15     ;
17   devel-pkgs = with pkgs; [
19     # For nix
20     nil
21     nixpkgs-fmt
23     # For go
24     gopls
26     # For bash
27     nodePackages.bash-language-server
28     shellcheck
30     # For typescript
31     nodePackages.typescript-language-server
32     nodePackages.prettier
33     nodePackages.http-server
35     # For lua
36     stylua
38     # other utilities
39     addlicense
40   ];
42   myCabin = toString ./.;
46   MYCABIN_ROOT="${myCabin}"
47   export MYCABIN_ROOT
48   PATH="${myCabin}/bin:${makeBinPath devel-pkgs}:$PATH"
49   export PATH