new
[libcurl.git] / curl-ssl.spec
blob1d69342d37e670d5c9ef3a19832f820cd5babfb1
1 %define name curl-ssl
2 %define tarball curl
3 %define version 6.0
4 %define release 1
5 %define prefix /usr/local
7 %define builddir $RPM_BUILD_DIR/%{tarball}-%{version}
9 Summary: get a file from a FTP, GOPHER or HTTP server.
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 Copyright: MPL
14 Vendor: Daniel Stenberg <Daniel.Stenberg@haxx.nu>
15 Packager: Troy Engel <tengel@sonic.net>
16 Group: Utilities/Console
17 Source: %{tarball}-%{version}.tar.gz
18 URL: http://curl.haxx.nu/
19 BuildRoot: /tmp/%{tarball}-%{version}-root
21 %description
22 curl is a client to get documents/files from servers, using any of the
23 supported protocols. The command is designed to work without user
24 interaction or any kind of interactivity.
26 curl offers a busload of useful tricks like proxy support, user
27 authentication, ftp upload, HTTP post, file transfer resume and more.
29 Note: this version is compiled with SSL (https:) support.
31 %prep
32 rm -rf $RPM_BUILD_ROOT
33 rm -rf %{builddir}
35 %setup -n %{tarball}-%{version}
37 %build
38 CFLAGS=$RPM_OPT_FLAGS ./configure --prefix=$RPM_BUILD_ROOT%{prefix} --with-ssl
39 make CFLAGS="-DUSE_SSLEAY -I/usr/include/openssl"
41 %install
42 make install-strip
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46 rm -rf %{builddir}
48 %files
49 %defattr(-,root,root)
50 %attr(0755,root,root) %{prefix}/bin/curl
51 %doc curl.1 README* CHANGES CONTRIBUTE FAQ FILES INSTALL LEGAL MPL-1.0.txt RESOURCES TODO perl/