Checking in changes prior to tagging of version 2.30.
[MogileFS-Utils.git] / MogileFS-Utils.spec
blob923cc9c36b0f2285f3764709ea8f9c0f4b47edf3
1 name: MogileFS-Utils
2 summary: MogileFS-Utils - MogileFS utilities.
3 version: 2.19
4 release: 1%{?dist}
5 vendor: Alan Kasindorf <dormando@rydia.net>
6 packager: Jonathan Steinert <rpm@hachi.kuiki.net>
7 license: Artistic
8 group: Applications/CPAN
9 buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
10 buildarch: noarch
11 source: MogileFS-Utils-%{version}.tar.gz
12 autoreq: no
13 requires: perl
14 requires: perl(MogileFS::Client) >= 1.14
15 requires: perl(Compress::Zlib)
17 %description
18 MogileFS utilities.
20 %prep
21 rm -rf "%{buildroot}"
22 %setup -n MogileFS-Utils-%{version}
24 %build
25 %{__perl} Makefile.PL PREFIX=%{buildroot}%{_prefix}
26 make all
27 make test
29 %install
30 make pure_install
32 [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
34 # remove special files
35 find %{buildroot} \( \
36 -name "perllocal.pod" \
37 -o -name ".packlist" \
38 -o -name "*.bs" \
39 \) -exec rm -f {} \;
41 # no empty directories
42 find %{buildroot}%{_prefix} \
43 -type d -depth -empty \
44 -exec rmdir {} \;
46 %clean
47 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
49 %files
50 %defattr(-,root,root)
51 %{_prefix}/bin/*
52 %{_prefix}/share/man/man1/*
53 %{_prefix}/share/man/man3/*
54 %{_prefix}/lib/perl5/site_perl/*