Added .rc file support for Win16 NE modules.
[wine.git] / dlls / display / display.spec
blobc475a956383c1bf1689fff6f9e35189b031dcfa4
1 name display
2 type win16
4 1 stub BitBlt
5 2 stub ColorInfo
6 3 stub Control
7 4 stub Disable
8 5 stub Enable
9 6 stub EnumFonts
10 7 stub EnumObj
11 8 stub Output
12 9 stub Pixel
13 10 stub RealizeObject
14 11 stub StrBlt
15 12 stub ScanLR
16 13 stub DeviceMode
17 14 stub ExtTextOut
18 15 stub GetCharWidth
19 16 stub DeviceBitmap
20 17 stub FastBorder
21 18 stub SetAttribute
22 19 stub DeviceBitmapBits
23 20 stub CreateBitmap
24 21 stub DIBScreenBlt
26 # ATI driver exports
27 22 stub SetPalette
28 23 stub GetPalette
29 24 stub SetPaletteTranslate
30 25 stub GetPaletteTranslate
31 26 stub UpdateColors
32 27 stub StretchBlt
33 28 stub StrechDIBits
34 29 stub SelectBitmap
35 30 stub BitmapBits
36 31 stub ReEnable
37 # these conflict with ordinals 19-21, thus relocated to 39-41 !
38 39 stub DIBBlt
39 40 stub CreateDIBitmap
40 41 stub DIBToDevice
41 # ATI driver end
43 90 stub Do_Polylines
44 91 stub Do_Scanlines
45 92 stub SaveScreenBitmap
46 101 pascal16 Inquire(ptr) DISPLAY_Inquire
47 102 pascal16 SetCursor(ptr) DISPLAY_SetCursor
48 103 pascal16 MoveCursor(word word) DISPLAY_MoveCursor
49 104 pascal16 CheckCursor() DISPLAY_CheckCursor
50 400 stub PExtTextOut
51 401 stub PStrBlt
52 402 stub RExtTextOut
53 403 stub RStrBlt
54 450 pascal GetDriverResourceID(word str) DISPLAY_GetDriverResourceID
55 500 pascal16 UserRepaintDisable(word) UserRepaintDisable16
56 501 stub ORDINAL_ONLY1
57 502 stub ORDINAL_ONLY2
58 600 stub InkReady
59 601 stub GetLPDevice