mshtml: Implement MediaQueryList's addListener method.
[wine.git] / dlls / rasapi32 / rasapi32.spec
blob783da6be10226f7ace525bec6d48a3455253b334
1 # @ stub DDMComputeLuid
2 # @ stub DDMFreeDialingParam
3 # @ stub DDMFreePhonebookContext
4 # @ stub DDMFreeRemoteEndpoint
5 # @ stub DDMGetAddressesFromPhonebook
6 # @ stub DDMGetEapInfo
7 # @ stub DDMGetEapUserIdentityW
8 # @ stub DDMGetPhoneBookContext
9 # @ stub DDMGetPhonebookInfo
10 # @ stub DDMGetProtocolStartParams
11 # @ stub DDMGetRasDialParams
12 # @ stub DDMGetRasDialingParams
13 # @ stub DDMGetTunnelEndpoints
14 # @ stub DDMRasPbkEntryCleanup
15 # @ stub DDMUpdateProtocolConfigInfoFromEntry
16 # @ stub DwCloneEntry
17 # @ stub DwEnumEntryDetails
18 # @ stub DwEnumEntryDetailsEx
19 # @ stub DwRasUninitialize
20 # @ stub GetAutoTriggerProfileInfo
21 # @ stub IsActiveAutoTriggerConnection
22 # @ stub IsActiveAutoTriggerConnectionEx
23 # @ stub RasAutoDialSharedConnection
24 @ stub RasAutodialAddressToNetwork
25 @ stub RasAutodialEntryToNetwork
26 @ stub RasClearConnectionStatistics
27 # @ stub RasClearLinkStatistics
28 # @ stub RasCompleteDialMachineCleanup
29 # @ stub RasConfigUserProxySettingsW
30 @ stdcall RasConnectionNotificationA(ptr long long)
31 @ stdcall RasConnectionNotificationW(ptr long long)
32 @ stdcall RasCreatePhonebookEntryA(long str)
33 @ stdcall RasCreatePhonebookEntryW(long wstr)
34 @ stdcall RasDeleteEntryA(str str)
35 @ stdcall RasDeleteEntryW(wstr wstr)
36 @ stdcall RasDeleteSubEntryA(str str long)
37 @ stdcall RasDeleteSubEntryW(wstr wstr long)
38 @ stdcall RasDialA(ptr str ptr long ptr ptr)
39 @ stdcall RasDialW(ptr wstr ptr long ptr ptr)
40 @ stub RasDialWow
41 @ stdcall RasEditPhonebookEntryA(long str str)
42 @ stdcall RasEditPhonebookEntryW(long wstr wstr)
43 @ stdcall RasEnumAutodialAddressesA(ptr ptr ptr)
44 @ stdcall RasEnumAutodialAddressesW(ptr ptr ptr)
45 @ stdcall RasEnumConnectionsA(ptr ptr ptr)
46 @ stdcall RasEnumConnectionsW(ptr ptr ptr)
47 @ stub RasEnumConnectionsWow
48 @ stdcall RasEnumDevicesA(ptr ptr ptr)
49 @ stdcall RasEnumDevicesW(ptr ptr ptr)
50 @ stdcall RasEnumEntriesA(str str ptr ptr ptr)
51 @ stdcall RasEnumEntriesW(wstr wstr ptr ptr ptr)
52 @ stub RasEnumEntriesWow
53 # @ stub RasFreeEapUserIdentityA
54 # @ stub RasFreeEapUserIdentityW
55 # @ stub RasFreeEntryAdvancedProperties
56 # @ stub RasGetAutoTriggerConnectStatus
57 @ stdcall RasGetAutodialAddressA(str ptr ptr ptr ptr)
58 @ stdcall RasGetAutodialAddressW(wstr ptr ptr ptr ptr)
59 @ stdcall RasGetAutodialEnableA(long ptr)
60 @ stdcall RasGetAutodialEnableW(long ptr)
61 @ stdcall RasGetAutodialParamA(long ptr ptr)
62 @ stdcall RasGetAutodialParamW(long ptr ptr)
63 @ stub RasGetConnectResponse
64 @ stdcall RasGetConnectStatusA(ptr ptr)
65 @ stdcall RasGetConnectStatusW(ptr ptr)
66 @ stub RasGetConnectStatusWow
67 # @ stub RasGetConnectionErrorStringW
68 @ stdcall RasGetConnectionStatistics(ptr ptr)
69 @ stub RasGetCountryInfoA
70 @ stub RasGetCountryInfoW
71 @ stub RasGetCredentialsA
72 @ stub RasGetCredentialsW
73 # @ stub RasGetCustomAuthDataA
74 # @ stub RasGetCustomAuthDataW
75 # @ stub RasGetEapUserDataA
76 # @ stub RasGetEapUserDataW
77 # @ stub RasGetEapUserIdentityA
78 # @ stub RasGetEapUserIdentityW
79 # @ stub RasGetEntryAdvancedProperties
80 @ stdcall RasGetEntryDialParamsA(str ptr ptr)
81 @ stdcall RasGetEntryDialParamsW(wstr ptr ptr)
82 # @ stub RasGetEntryHrasconnW
83 @ stdcall RasGetEntryPropertiesA(str str ptr ptr ptr ptr)
84 @ stdcall RasGetEntryPropertiesW(wstr wstr ptr ptr ptr ptr)
85 @ stdcall RasGetErrorStringA(long ptr long)
86 @ stdcall RasGetErrorStringW(long ptr long)
87 @ stub RasGetErrorStringWow
88 @ stub RasGetHport
89 @ stdcall RasGetLinkStatistics(ptr long ptr)
90 # @ stub RasGetNapStatus
91 # @ stub RasGetPCscf
92 # @ stub RasGetPbkPath
93 @ stdcall RasGetProjectionInfoA(ptr ptr ptr ptr)
94 # @ stub RasGetProjectionInfoEx
95 @ stdcall RasGetProjectionInfoW(ptr ptr ptr ptr)
96 @ stub RasGetSubEntryHandleA
97 @ stub RasGetSubEntryHandleW
98 @ stub RasGetSubEntryPropertiesA
99 @ stub RasGetSubEntryPropertiesW
100 # @ stub RasHandleTriggerConnDisconnect
101 @ stdcall RasHangUpA(long)
102 @ stdcall RasHangUpW(long)
103 @ stub RasHangUpWow
104 # @ stub RasInvokeEapUI
105 # @ stub RasIsPublicPhonebook
106 # @ stub RasIsSharedConnection
107 # @ stub RasNQMStateEnteredNotification
108 # @ stub RasQueryRedialOnLinkFailure
109 # @ stub RasQuerySharedAutoDial
110 # @ stub RasQuerySharedConnection
111 # @ stub RasRegisterEntryChangeNotification
112 @ stdcall RasRenameEntryA(str str str)
113 @ stdcall RasRenameEntryW(wstr wstr wstr)
114 # @ stub RasRestoreDefaultLegacyProxySettings
115 # @ stub RasScriptExecute
116 # @ stub RasScriptGetIpAddress
117 # @ stub RasScriptInit
118 # @ stub RasScriptReceive
119 # @ stub RasScriptSend
120 # @ stub RasScriptTerm
121 # @ stub RasSetAutoTriggerProfile
122 # @ stub RasSetAutoTriggerProfileEx
123 @ stdcall RasSetAutodialAddressA(str long ptr long long)
124 @ stdcall RasSetAutodialAddressW(wstr long ptr long long)
125 @ stdcall RasSetAutodialEnableA(long long)
126 @ stdcall RasSetAutodialEnableW(long long)
127 @ stdcall RasSetAutodialParamA(long ptr long)
128 @ stdcall RasSetAutodialParamW(long ptr long)
129 @ stdcall RasSetCredentialsA(str str ptr long)
130 @ stdcall RasSetCredentialsW(wstr wstr ptr long)
131 @ stdcall RasSetCustomAuthDataA(str str ptr long)
132 @ stdcall RasSetCustomAuthDataW(wstr wstr ptr long)
133 # @ stub RasSetEapUserDataA
134 # @ stub RasSetEapUserDataAEx
135 # @ stub RasSetEapUserDataW
136 # @ stub RasSetEapUserDataWEx
137 # @ stub RasSetEntryAdvancedProperties
138 @ stdcall RasSetEntryDialParamsA(str ptr long)
139 @ stdcall RasSetEntryDialParamsW(wstr ptr long)
140 @ stdcall RasSetEntryPropertiesA(str str ptr long ptr long)
141 @ stdcall RasSetEntryPropertiesW(wstr wstr ptr long ptr long)
142 @ stub RasSetOldPassword
143 # @ stub RasSetPerConnectionProxy
144 # @ stub RasSetSharedAutoDial
145 @ stdcall RasSetSubEntryPropertiesA(str str long ptr long ptr long)
146 @ stdcall RasSetSubEntryPropertiesW(wstr wstr long ptr long ptr long)
147 # @ stub RasTriggerConnection
148 # @ stub RasTriggerConnectionEx
149 # @ stub RasTriggerDisconnection
150 # @ stub RasTriggerDisconnectionEx
151 # @ stub RasUnregisterEntryChangeNotification
152 # @ stub RasUpdateConnection
153 @ stdcall RasValidateEntryNameA(str str)
154 @ stdcall RasValidateEntryNameW(wstr wstr)
155 # stub @ RasWriteSharedPbkOptions
156 # stub @ UnInitializeRAS
158 500 stub RnaEngineRequest
159 501 stub DialEngineRequest
160 502 stub SuprvRequest
161 503 stub DialInMessage
162 504 stub RnaEnumConnEntries
163 505 stub RnaGetConnEntry
164 506 stub RnaFreeConnEntry
165 507 stub RnaSaveConnEntry
166 508 stub RnaDeleteConnEntry
167 509 stub RnaRenameConnEntry
168 510 stub RnaValidateEntryName
169 511 stub RnaEnumDevices
170 512 stub RnaGetDeviceInfo
171 513 stub RnaGetDefaultDevConfig
172 514 stub RnaBuildDevConfig
173 515 stub RnaDevConfigDlg
174 516 stub RnaFreeDevConfig
175 517 stub RnaActivateEngine
176 518 stub RnaDeactivateEngine
177 519 stub SuprvEnumAccessInfo
178 520 stub SuprvGetAccessInfo
179 521 stub SuprvSetAccessInfo
180 522 stub SuprvGetAdminConfig
181 523 stub SuprvInitialize
182 524 stub SuprvDeInitialize
183 525 stub RnaUIDial
184 526 stub RnaImplicitDial
185 527 stub RasDial16
186 528 stub RnaSMMInfoDialog
187 529 stub RnaEnumerateMacNames
188 530 stub RnaEnumCountryInfo
189 531 stub RnaGetAreaCodeList
190 532 stub RnaFindDriver
191 533 stub RnaInstallDriver
192 534 stub RnaGetDialSettings
193 535 stub RnaSetDialSettings
194 536 stub RnaGetIPInfo
195 537 stub RnaSetIPInfo
197 560 stub RnaCloseMac
198 561 stub RnaComplete
199 562 stub RnaGetDevicePort
200 563 stub RnaGetUserProfile
201 564 stub RnaOpenMac
202 565 stub RnaSessInitialize
203 566 stub RnaStartCallback
204 567 stub RnaTerminate
205 568 stub RnaUICallbackDialog
206 569 stub RnaUIUsernamePassword