Updated qca plugins.
[underlay.git] / app-crypt / qca-logger / qca-logger-0.1_p20070829.ebuild
blobf7c7520fa3a8fc08ad5fb4f55a510fc6d365b5e6
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header:
5 inherit eutils qt4
7 QCA_VER="2.0-test3"
8 MY_PV="${PV/_p/-}"
9 MY_P="${PN}-${MY_PV}"
11 DESCRIPTION="Logger plugin for QCA"
12 HOMEPAGE="http://delta.affinix.com/qca/"
13 SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER/-*/}/${QCA_VER/*-/}/${MY_P}.tar.bz2"
15 LICENSE="LGPL-2"
16 SLOT="2"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="debug"
19 RESTRICT="strip"
21 RDEPEND=">=app-crypt/qca-2.0.0_rc2"
22 DEPEND="${RDEPEND}"
24 S="${WORKDIR}/${MY_P}"
26 pkg_setup() {
27 if use debug && ! built_with_use '>=app-crypt/qca-2.0.0_rc' debug; then
28 einfo
29 einfo "You are trying to compile ${PN} package with active USE=\"debug\""
30 einfo "while qca is build without this particular flag. It will not"
31 einfo "work."
32 einfo
33 einfo "Possible solutions to this problem are:"
34 einfo "a) install package ${PN} without debug USE flag"
35 einfo "b) re-emerge qca with debug USE flag"
36 einfo
37 die "can't emerge ${PN} with debug USE flag"
41 src_compile() {
42 local myconf=
44 if use debug; then
45 myconf="--debug-and-release"
46 else
47 myconf="--release"
50 ./configure \
51 --qtdir=/usr \
52 --no-separate-debug-info \
53 ${myconf} || die "configure failed"
55 eqmake4 ${PN}.pro
56 emake || die "make failed"
59 src_install() {
60 emake INSTALL_ROOT="${D}" install || die "make install failed"
61 dodoc README