Added x11-themes/smplayer-themes (icon themes for
[underlay.git] / net-wireless / madwifi-ng-tools / madwifi-ng-tools-0.9.4_pre20070801.ebuild
blob13df9d94db1c4a9d9e7f1c8cba705d0e84edaed5
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit toolchain-funcs
7 MY_REV="2628"
8 MY_P=${PN%-tools}-r${MY_REV}-${PV##*_pre}
9 S=${WORKDIR}/${MY_P}/tools
11 DESCRIPTION="Next Generation tools for configuration of Atheros based IEEE 802.11a/b/g wireless LAN cards"
12 HOMEPAGE="http://www.madwifi.org/"
13 SRC_URI="http://snapshots.madwifi.org/${PN%-tools}/${MY_P}.tar.gz"
14 RESTRICT="mirror"
16 LICENSE="|| ( BSD GPL-2 )"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
21 DEPEND="virtual/libc"
22 RDEPEND="!net-wireless/madwifi-old-tools
23 ${DEPEND}"
25 src_unpack() {
26 unpack ${A}
28 einfo "S=$S"
29 einfo "PV=$PV"
31 sed -i -e "s:CC =.*:CC = $(tc-getCC):" \
32 -e "s:CFLAGS=:CFLAGS+=:" \
33 -e "s:LDFLAGS=:LDFLAGS+=:" \
34 "${S}"/Makefile || die "sed failed"
37 src_compile() {
38 emake || die "make failed"
41 src_install() {
42 emake DESTDIR="${D}" BINDIR=/usr/bin MANDIR=/usr/share/man STRIP=echo \
43 install || die "install failed"
45 dodir /sbin
46 mv "${D}"/usr/bin/wlanconfig "${D}"/sbin
48 # install headers for use by
49 # net-wireless/wpa_supplicant and net-wireless/hostapd
50 cd "${S}"/..
51 insinto /usr/include/madwifi/include/
52 doins include/*.h
53 insinto /usr/include/madwifi/net80211
54 doins net80211/*.h
57 pkg_postinst() {
58 if [ -e "${ROOT}"/etc/udev/rules.d/65-madwifi.rules ]; then
59 ewarn
60 ewarn "The udev rules for creating interfaces (athX) are no longer needed."
61 ewarn
62 ewarn "You should manually remove the /etc/udev/rules.d/65-madwifi.rules file"
63 ewarn "and either run 'udevstart' or reboot for the changes to take effect."
64 ewarn
66 einfo
67 einfo "If you use net-wireless/wpa_supplicant or net-wireless/hostapd with madwifi"
68 einfo "you should remerge them now."
69 einfo