contrib: switch to pkgconfig() where possible
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blobbc07aa3f6b2005a93cfd9b3c4578a3c75fa20a16
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
8 # Mageia
9 # Windows (mingw32, mingw64)
12 # Build options
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
21 # <arch>i586</arch>
22 # </repository>
24 %if "%{_repository}" == "mingw32"
25 %define purple_sipe_mingw32 1
26 %define mingw_prefix mingw32-
27 %define mingw_cache %{_mingw32_cache}
28 %define mingw_configure %{_mingw32_configure}
29 %define mingw_datadir %{_mingw32_datadir}
30 %define mingw_debug_package %{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir %{_mingw32_libdir}
33 %define mingw_make %{_mingw32_make}
34 %define mingw_makeinstall %{_mingw32_makeinstall}
35 %define __strip %{_mingw32_strip}
36 %define __objdump %{_mingw32_objdump}
37 %define _use_internal_dependency_generator 0
38 %define __find_requires %{_mingw32_findrequires}
39 %define __find_provides %{_mingw32_findprovides}
40 %define __os_install_post %{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
42 %endif
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
50 # <arch>i586</arch>
51 # </repository>
53 %if "%{_repository}" == "mingw64"
54 %define purple_sipe_mingw64 1
55 %define mingw_prefix mingw64-
56 %define mingw_cache %{_mingw64_cache}
57 %define mingw_configure %{_mingw64_configure}
58 %define mingw_datadir %{_mingw64_datadir}
59 %define mingw_debug_package %{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir %{_mingw64_libdir}
62 %define mingw_make %{_mingw64_make}
63 %define mingw_makeinstall %{_mingw64_makeinstall}
64 %define __strip %{_mingw64_strip}
65 %define __objdump %{_mingw64_objdump}
66 %define _use_internal_dependency_generator 0
67 %define __find_requires %{_mingw64_findrequires}
68 %define __find_provides %{_mingw64_findprovides}
69 %define __os_install_post %{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
71 %endif
73 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
74 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
75 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
76 %define common_files sipe-common
77 %define empathy_files empathy-sipe
78 %define ktp_files ktp-accounts-kcm-sipe
81 %define has_pidgin 1
83 %if 0%{?mageia}
84 %define has_appdata 1
85 %define has_gstreamer 1
86 %endif
88 %if 0%{?suse_version}
89 %define has_appdata 1
90 %define has_gstreamer 1
91 %define build_telepathy 1
92 %endif
94 %if 0%{?suse_version} || 0%{?sles_version}
95 %define pkg_group Productivity/Networking/Instant Messenger
96 %else
97 %define pkg_group Applications/Communications
98 %endif
100 # workaround for Fedora Rawhide
101 %if 0%{?fedora_version}
102 %if 0%{?fedora}
103 %else
104 %define fedora %{?fedora_version}
105 %endif
106 %endif
108 %if 0%{?fedora}
109 %define has_appdata 1
110 %define has_gssntlmssp 1
111 %define has_gstreamer 1
112 %define build_telepathy 1
113 %define build_ktp 1
114 %endif
116 %if 0%{?centos_version} || 0%{?scientificlinux_version}
117 %define has_krb5devel 1
118 %define rhel_base_version %{?centos_version}%{?scientificlinux_version}
119 %if %{rhel_base_version} >= 700
120 # pidgin has been removed, but libpurple still exists
121 %define has_pidgin 0
122 %endif
123 %endif
125 %if 0%{?purple_sipe_mingw32}
126 Name: mingw32-pidgin-sipe
127 %else
128 %if 0%{?purple_sipe_mingw64}
129 Name: mingw64-pidgin-sipe
130 %else
131 Name: pidgin-sipe
132 %endif
133 %endif
134 Summary: Pidgin protocol plugin to connect to MS Office Communicator
135 Version: 1.23.0
136 Release: 1
137 Source: pidgin-sipe-%{version}.tar.gz
138 Group: %{pkg_group}
139 License: GPLv2+
140 URL: http://sipe.sourceforge.net/
142 BuildRoot: %{_tmppath}/%{name}-%{version}-build
144 %if 0%{?mingw_prefix:1}
146 # Windows cross-compilation build setup
148 BuildArch: noarch
149 #!BuildIgnore: post-build-checks
151 BuildRequires: libtool
152 BuildRequires: intltool
153 BuildRequires: %{mingw_prefix}filesystem >= 23
154 BuildRequires: %{mingw_prefix}cross-gcc
155 BuildRequires: %{mingw_prefix}cross-binutils
156 BuildRequires: %{mingw_prefix}gettext-runtime
157 BuildRequires: %{mingw_prefix}cross-pkg-config
158 BuildRequires: %{mingw_prefix}glib2-devel >= 2.18.0
159 BuildRequires: %{mingw_prefix}libxml2-devel
160 BuildRequires: %{mingw_prefix}mozilla-nss-devel
161 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.7.0
162 BuildRequires: %{mingw_prefix}cross-nsis
164 # For directory ownership
165 BuildRequires: %{mingw_prefix}pidgin
167 # Make sure telepathy is disabled for Windows builds
168 %undefine build_telepathy
170 %else
172 # Standard Linux build setup
174 BuildRequires: libtool
175 BuildRequires: intltool
176 BuildRequires: pkgconfig(dbus-1)
177 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
178 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
179 BuildRequires: pkgconfig(libxml-2.0)
180 BuildRequires: pkgconfig(nss)
181 BuildRequires: pkgconfig(purple) >= 2.7.0
182 %if 0%{?mageia}
183 # It seems linking against -lpurple is severely broken on Mageia...
184 BuildRequires: pkgconfig(libgadu)
185 %endif
186 %if 0%{?has_gstreamer:1}
187 BuildRequires: pkgconfig(farstream-0.2)
188 BuildRequires: pkgconfig(gio-2.0)
189 BuildRequires: pkgconfig(gstreamer-1.0)
190 BuildRequires: pkgconfig(nice) >= 0.1.0
191 %endif
192 # Requirements for telepathy backend
193 %if 0%{?build_telepathy:1}
194 BuildRequires: gmime-devel
195 BuildRequires: pkgconfig(dbus-glib-1)
196 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
197 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
198 BuildRequires: pkgconfig(gobject-2.0)
199 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
200 %endif
202 # Configurable components
203 # Use "--without kerberos" to disable krb5
204 %if !0%{?_without_kerberos:1}
205 %if 0%{?has_krb5devel:1}
206 BuildRequires: krb5-devel
207 %else
208 BuildRequires: pkgconfig(krb5)
209 %endif
210 %if 0%{?has_gssntlmssp:1}
211 BuildRequires: gssntlmssp-devel >= 0.5.0
212 Requires: gssntlmssp >= 0.5.0
213 %endif
214 %endif
216 # For directory ownership
217 %if %{has_pidgin}
218 BuildRequires: pidgin
219 Requires: pidgin
220 %endif
221 %if 0%{?build_telepathy:1}
222 BuildRequires: empathy
223 %endif
225 # End Windows cross-compilation/Linux build setup
226 %endif
228 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
231 %description
232 A third-party plugin for the Pidgin multi-protocol instant messenger.
233 It implements the extended version of SIP/SIMPLE used by various products:
235 * Skype for Business
236 * Microsoft Office 365
237 * Microsoft Business Productivity Online Suite (BPOS)
238 * Microsoft Lync Server
239 * Microsoft Office Communications Server (OCS 2007/2007 R2)
240 * Microsoft Live Communications Server (LCS 2003/2005)
242 With this plugin you should be able to replace your Microsoft Office
243 Communicator client with Pidgin.
245 This package provides the icon set for Pidgin.
248 %package -n %{purple_plugin}
249 Summary: Libpurple protocol plugin to connect to MS Office Communicator
250 Group: %{pkg_group}
251 License: GPLv2+
252 Obsoletes: purple-sipe
253 %if 0%{?build_telepathy:1}
254 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
255 %endif
257 %description -n %{purple_plugin}
258 A third-party plugin for the Pidgin multi-protocol instant messenger.
259 It implements the extended version of SIP/SIMPLE used by various products:
261 * Skype for Business
262 * Microsoft Office 365
263 * Microsoft Business Productivity Online Suite (BPOS)
264 * Microsoft Lync Server
265 * Microsoft Office Communications Server (OCS 2007/2007 R2)
266 * Microsoft Live Communications Server (LCS 2003/2005)
268 This package provides the protocol plugin for libpurple clients.
271 %if 0%{?build_telepathy:1}
272 %package -n %{empathy_files}
273 Summary: Telepathy connection manager to connect to MS Office Communicator
274 Group: %{pkg_group}
275 License: GPLv2+
276 Requires: empathy
277 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
279 %description -n %{empathy_files}
280 A Telepathy connection manager that implements the extended version of
281 SIP/SIMPLE used by various products:
283 * Skype for Business
284 * Microsoft Office 365
285 * Microsoft Business Productivity Online Suite (BPOS)
286 * Microsoft Lync Server
287 * Microsoft Office Communications Server (OCS 2007/2007 R2)
288 * Microsoft Live Communications Server (LCS 2003/2005)
290 This package provides the icon set for Empathy.
293 %if 0%{?build_ktp:1}
294 %package -n %{ktp_files}
295 Summary: Telepathy connection manager to connect to MS Office Communicator
296 Group: %{pkg_group}
297 License: GPLv2+
298 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
300 %description -n %{ktp_files}
301 A Telepathy connection manager that implements the extended version of
302 SIP/SIMPLE used by various products:
304 * Skype for Business
305 * Microsoft Office 365
306 * Microsoft Business Productivity Online Suite (BPOS)
307 * Microsoft Lync Server
308 * Microsoft Office Communications Server (OCS 2007/2007 R2)
309 * Microsoft Live Communications Server (LCS 2003/2005)
311 This package provides the profile for KTP account manager.
312 %endif
315 %package -n %{telepathy_plugin}
316 Summary: Telepathy connection manager to connect to MS Office Communicator
317 Group: %{pkg_group}
318 License: GPLv2+
319 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
321 %description -n %{telepathy_plugin}
322 A Telepathy connection manager that implements the extended version of
323 SIP/SIMPLE used by various products:
325 * Skype for Business
326 * Microsoft Office 365
327 * Microsoft Business Productivity Online Suite (BPOS)
328 * Microsoft Lync Server
329 * Microsoft Office Communications Server (OCS 2007/2007 R2)
330 * Microsoft Live Communications Server (LCS 2003/2005)
332 This package provides the protocol support for Telepathy clients.
335 %package -n %{common_files}
336 Summary: Common files for SIPE protocol plugins
337 Group: %{pkg_group}
338 License: GPLv2+
339 BuildArch: noarch
341 %description -n %{common_files}
342 This package provides common files for the SIPE protocol plugins:
344 * Localisation
345 %endif
348 %if 0%{?mingw_prefix:1}
349 %package -n %{nsis_package}
350 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
351 Group: %{pkg_group}
352 License: GPLv2+
354 %description -n %{nsis_package}
355 A third-party plugin for the Pidgin multi-protocol instant messenger.
356 It implements the extended version of SIP/SIMPLE used by various products:
358 * Skype for Business
359 * Microsoft Office 365
360 * Microsoft Business Productivity Online Suite (BPOS)
361 * Microsoft Lync Server
362 * Microsoft Office Communications Server (OCS 2007/2007 R2)
363 * Microsoft Live Communications Server (LCS 2003/2005)
365 This package contains the NSIS installer package of the protocol plugin
366 for Pidgin on Windows.
367 %endif
370 %{mingw_debug_package}
373 %prep
374 %setup -q -n pidgin-sipe-%{version}
376 %build
377 %if 0%{?mingw_prefix:1}
379 # Windows cross-compilation build
381 %{?env_options}
382 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
383 autoreconf --verbose --install --force
384 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
385 %{mingw_configure} \
386 --enable-purple \
387 %if 0%{?build_telepathy:1}
388 --enable-telepathy
389 %else
390 --disable-telepathy
391 %endif
392 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
394 %else
396 # Standard Linux build
398 # Special case handling for Mageia
399 %if 0%{?mageia}
400 %configure2_5x \
401 --with-krb5 \
402 --disable-telepathy
403 %make_build
404 %make_build check
406 # All other Linuxes
407 %else
408 %configure \
409 %if !0%{?_without_kerberos:1}
410 --with-krb5 \
411 %endif
412 --enable-purple \
413 %if 0%{?build_telepathy:1}
414 --enable-telepathy
415 %else
416 --disable-telepathy
417 %endif
418 make %{?_smp_mflags}
419 make %{?_smp_mflags} check
420 %endif
422 # End Windows cross-compilation/Linux build setup
423 %endif
426 %install
427 %if 0%{?mingw_prefix:1}
429 # Windows cross-compilation install
431 %{mingw_makeinstall}
432 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
434 # generate .dbgsym file
435 rm -f %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
436 mv \
437 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
438 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
439 %{__strip} --strip-unneeded \
440 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym \
441 -o %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
443 # generate NSIS installer package
444 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
445 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
446 >%{buildroot}/pidgin-sipe.nsi
448 set -e; \
449 cd %{buildroot}; \
450 makensis \
451 -DPIDGIN_VERSION=UNKNOWN \
452 -DVERSION=%{version} \
453 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
454 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
455 pidgin-sipe.nsi \
457 rm -f %{buildroot}/pidgin-sipe.nsi
459 %else
461 # Standard Linux install
463 %make_install
465 # End Windows cross-compilation/Linux build setup
466 %endif
468 find %{buildroot} -type f -name "*.la" -delete -print
469 # Pidgin doesn't have 24 or 32 pixel icons
470 rm -f \
471 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
472 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
473 %if !0%{?has_appdata:1}
474 # We don't have AppStream, so we can't package metadata file at all
475 rm -r %{buildroot}/%{_datadir}/appdata
476 %endif
477 %if !%{has_pidgin}
478 # We don't have Pidgin, so we can't package icons at all
479 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin
480 %endif
481 %if 0%{?build_telepathy:1}
482 %if !0%{?build_ktp:1}
483 rm -r %{buildroot}%{_datadir}/telepathy
484 %endif
485 %endif
486 %find_lang pidgin-sipe
489 %clean
490 rm -rf %{buildroot}
493 %if 0%{?build_telepathy:1}
494 %files -n %{purple_plugin}
495 %else
496 %files -n %{purple_plugin} -f pidgin-sipe.lang
497 %endif
498 %defattr(-,root,root,-)
499 %doc AUTHORS ChangeLog COPYING NEWS README TODO
500 %if 0%{?mingw_prefix:1}
501 %{mingw_libdir}/purple-2/libsipe.dll
502 %{mingw_libdir}/purple-2/libsipe.dll.dbgsym
503 %else
504 %{_libdir}/purple-2/libsipe.so
505 %endif
508 %if 0%{?build_telepathy:1}
509 %files -n %{empathy_files}
510 %defattr(-,root,root,-)
511 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
512 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
515 %if 0%{?build_ktp:1}
516 %files -n %{ktp_files}
517 %defattr(-,root,root,-)
518 %doc AUTHORS COPYING
519 %{_datadir}/telepathy/profiles/sipe.profile
520 %endif
523 %files -n %{telepathy_plugin}
524 %defattr(-,root,root,-)
525 %doc AUTHORS ChangeLog COPYING NEWS README TODO
526 %{_datadir}/dbus-1/services/*.sipe.service
527 %{_libexecdir}/telepathy-sipe
530 %files -n %{common_files} -f pidgin-sipe.lang
531 %defattr(-,root,root,-)
532 %endif
535 %files
536 %defattr(-,root,root,-)
537 %doc AUTHORS COPYING
538 %if 0%{?mingw_prefix:1}
539 %if 0%{?has_appdata:1}
540 %{mingw_datadir}/appdata/pidgin-sipe.metainfo.xml
541 %endif
542 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
543 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
544 %else
545 %if %{has_pidgin}
546 %if 0%{?has_appdata:1}
547 %{_datadir}/appdata/%{name}.metainfo.xml
548 %endif
549 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
550 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
551 %endif
552 %endif
555 %if 0%{?mingw_prefix:1}
556 %files -n %{nsis_package}
557 %defattr(-, root, root)
558 /pidgin-sipe-%{version}.exe
559 %endif
562 %changelog
563 * DDD MMM DD 2017 J. D. User <jduser@noreply.com> 1.23.0
564 - update to 1.23.0
565 - raise BR glib-2.0 >= 2.18.0
566 - raise BR purple >= 2.7.0
568 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
569 - add BR dbus-1
570 - fix incorrect BR gstreamer-0.10 when gstreamer-1.0 is selected
572 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
573 - update to 1.22.1
575 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
576 - update to 1.22.0
578 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
579 - add BR gio-2.0
581 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
582 - add BR farstream-0.2
584 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
585 - update to 1.21.1
587 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
588 - update to 1.21.0
590 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
591 - align with Fedora SPEC file
593 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
594 - add AppStream metadata file
596 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
597 - add dependency on pkgconfig(gstreamer-1.0) for F22+ & Leap 42.1+
599 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
600 - update to 1.20.1
602 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
603 - we also support "Skype for Business"
605 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
606 - update to 1.20.0
608 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
609 - update to 1.19.1
611 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
612 - update to 1.19.0
614 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
615 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
617 * Mon Jan 05 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
618 - remove support for obsolete distributions
619 - Fedora < 19
620 - Mandriva
621 - OpenSUSE < 13.x
623 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
624 - update to 1.18.5
626 * Thu Dec 18 2014 J. D. User <jduser@noreply.com> 1.18.4-*git*
627 - improve support for CentOS & Scientific Linux
629 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
630 - update to 1.18.4
632 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
633 - update to 1.18.3
635 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
636 - update to 1.18.2
638 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
639 - update to 1.18.1
641 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
642 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
644 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
645 - update to 1.18.0
647 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
648 - update to 1.17.3
650 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
651 - update to 1.17.2
653 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
654 - update to 1.17.1
656 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
657 - update to 1.17.0
659 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
660 - update to 1.16.1
662 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
663 - update to 1.16.0
665 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
666 - update to 1.15.1
668 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
669 - update package description texts
671 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
672 - update to 1.15.0
674 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
675 - update to 1.14.1
677 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
678 - update to 1.14.0
680 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
681 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
683 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
684 - BR telepathy-glib-devel >= 0.18.0
686 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
687 - BR telepathy-glib-devel >= 0.14.0
689 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
690 - really disable telepathy for Windows cross-compilation builds
692 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
693 - updates to enable telepathy build
695 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
696 - update to 1.13.3
698 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
699 - update to 1.13.2
701 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
702 - update to 1.13.1
704 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
705 - update to 1.13.0
707 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
708 - we do support Microsoft Lync Server 2010 now.
710 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
711 - update GPL2 license name
713 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
714 - add BR gmime-devel for Fedora to have at least one verification platform
716 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
717 - fix Mandriva 2011 unresolvable BR
719 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
720 - add BR nss-devel
722 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
723 - add NSIS package for mingw builds
725 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
726 - add mingw64 build
728 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
729 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
731 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
732 - update mingw32 build
733 - update descriptions
735 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
736 - update to 1.12.0
738 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
739 - add gstreamer-devel to enable Voice & Video features
741 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
742 - add optional subpackage for telepathy connection manager
744 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
745 - update to 1.11.2
747 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
748 - update to 1.11.1
750 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
751 - add mingw32 build configuration
753 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
754 - update to 1.11.0
756 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
757 - Mandriva config for OBS has changed
759 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
760 - add libnice build information discovered through OBS testing
762 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
763 - add NSS build information discovered through OBS testing
765 * Sun Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
766 - release
768 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
769 - Mandriva has too old libtool version
771 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
772 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
774 * Thu Apr 01 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
775 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
777 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
778 - added --enable/--disable build options
780 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
781 - removed --with-krb5 configure option as it is autodetected now
783 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
784 - add SVG icon
786 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
787 - add BR glib2-devel >= 2.12.0
789 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
790 - add tests to build
792 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
793 - update to 1.9.1
795 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
796 - add BR libxml2-devel
798 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
799 - release
800 - dropped SLE 10 due to libpurple min version increase
801 - updated target distros in comment line
803 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
804 - increased libpurple build requisite to >= 2.4.0
806 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
807 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
809 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
810 - sync with RPM SPEC from contrib/rpm
812 * Mon Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
813 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
814 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
816 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
817 - reinstated enable-quality-check
819 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
820 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
822 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
823 - Spec file modifications for openSUSE build service
825 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
826 - move non-Pidgin files to new sub-package purple-sipe
828 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
829 - remove directory for emoticon theme icons
831 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
832 - libpurple protocol plugins are located under %%{_libdir}/purple-2
834 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
835 - added directory for emoticon theme icons
837 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
838 - update to 1.6.3
840 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
841 - reduce libpurple-devel requirement to >= 2.3.1
843 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
844 - update to 1.6.2
846 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
847 - reduce libpurple-devel requirement to >= 2.4.1
849 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
850 - com_err.h only required for kerberos
852 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
853 - require libpurple-devel >= 2.5.0
855 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
856 - refactor configure parameters
857 - make kerberos configurable
858 - don't hard code prefix for git builds
860 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
861 - removed unnecessary zlib-devel
863 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
864 - fix prefix for git builds
866 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
867 - append -Wno-unused-parameter for GCC <4.4 compilation errors
869 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
870 - remove duplicate GPL2
872 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
873 - use "--with git" to build from git
874 - corrected download URL for release archive
875 - add missing BR gettext-devel
877 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
878 - use default rpmbuild CFLAGS also for git builds
879 - merge with SPEC files created by mricon & jberanek
881 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
882 - initial RPM SPEC example generated