OBS: updates for Ubuntu 17.10
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob8ceb4568e1aa3e9286f0ca2274aea9aa05097b4a
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
8 # Windows (mingw32, mingw64)
11 # Build options
12 %undefine build_telepathy
14 # Check for mingw32 cross compilation build
16 # Manually add this repository to your private OBS project:
18 # <repository name="mingw32">
19 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
20 # <arch>i586</arch>
21 # </repository>
23 %if "%{_repository}" == "mingw32"
24 %define purple_sipe_mingw32 1
25 %define mingw_prefix mingw32-
26 %define mingw_cache %{_mingw32_cache}
27 %define mingw_configure %{_mingw32_configure}
28 %define mingw_datadir %{_mingw32_datadir}
29 %define mingw_debug_package %{_mingw32_debug_package}
30 %define mingw_ldflags MINGW32_LDFLAGS
31 %define mingw_libdir %{_mingw32_libdir}
32 %define mingw_make %{_mingw32_make}
33 %define mingw_makeinstall %{_mingw32_makeinstall}
34 %define __strip %{_mingw32_strip}
35 %define __objdump %{_mingw32_objdump}
36 %define _use_internal_dependency_generator 0
37 %define __find_requires %{_mingw32_findrequires}
38 %define __find_provides %{_mingw32_findprovides}
39 %define __os_install_post %{_mingw32_debug_install_post} \
40 %{_mingw32_install_post}
41 %endif
43 # Check for mingw64 cross compilation build
45 # Manually add this repository to your private OBS project:
47 # <repository name="mingw64">
48 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
49 # <arch>i586</arch>
50 # </repository>
52 %if "%{_repository}" == "mingw64"
53 %define purple_sipe_mingw64 1
54 %define mingw_prefix mingw64-
55 %define mingw_cache %{_mingw64_cache}
56 %define mingw_configure %{_mingw64_configure}
57 %define mingw_datadir %{_mingw64_datadir}
58 %define mingw_debug_package %{_mingw64_debug_package}
59 %define mingw_ldflags MINGW64_LDFLAGS
60 %define mingw_libdir %{_mingw64_libdir}
61 %define mingw_make %{_mingw64_make}
62 %define mingw_makeinstall %{_mingw64_makeinstall}
63 %define __strip %{_mingw64_strip}
64 %define __objdump %{_mingw64_objdump}
65 %define _use_internal_dependency_generator 0
66 %define __find_requires %{_mingw64_findrequires}
67 %define __find_provides %{_mingw64_findprovides}
68 %define __os_install_post %{_mingw64_debug_install_post} \
69 %{_mingw64_install_post}
70 %endif
72 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
73 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
74 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
75 %define common_files sipe-common
76 %define empathy_files empathy-sipe
77 %define ktp_files ktp-accounts-kcm-sipe
80 %define has_pidgin 1
82 %if 0%{?suse_version}
83 %define dbus_devel dbus-1-devel
84 %define nss_develname mozilla-nss-devel
85 # SLES11 defines suse_version = 1110
86 %if 0%{?suse_version} > 1110
87 %define has_appdata 1
88 %define has_libnice 1
89 %define has_gstreamer 1
90 %define build_telepathy 1
91 %define nice_gstreamer gstreamer-0_10-libnice
92 # Leap 42.1 or SLES12
93 %if 0%{?suse_version} >= 1315
94 %define has_gstreamer1 1
95 %define has_farstream 1
96 %undefine has_gstreamer
97 %undefine nice_gstreamer
98 %endif
99 %endif
100 %else
101 %define nss_develname nss-devel
102 %endif
104 %if 0%{?suse_version} || 0%{?sles_version}
105 %define pkg_group Productivity/Networking/Instant Messenger
106 %else
107 %define pkg_group Applications/Communications
108 %endif
110 # workaround for Fedora Rawhide
111 %if 0%{?fedora_version}
112 %if 0%{?fedora}
113 %else
114 %define fedora %{?fedora_version}
115 %endif
116 %endif
118 %if 0%{?fedora}
119 %define dbus_devel dbus-devel
120 %define has_libnice 1
121 %define has_gstreamer 1
122 %define build_telepathy 1
123 %define build_ktp 1
124 %if 0%{?fedora} >= 20
125 %define has_farstream 1
126 %define nice_gstreamer libnice-gstreamer
127 %if 0%{?fedora} >= 21
128 %define has_appdata 1
129 %define has_gssntlmssp 1
130 %if 0%{?fedora} >= 22
131 %define has_gstreamer1 1
132 %undefine has_gstreamer
133 %undefine nice_gstreamer
134 %endif
135 %endif
136 %endif
137 %endif
139 %if 0%{?centos_version} || 0%{?scientificlinux_version}
140 %define dbus_devel dbus-devel
141 %define rhel_base_version %{?centos_version}%{?scientificlinux_version}
142 %if %{rhel_base_version} >= 600
143 %define has_gstreamer 1
144 %define has_libnice 1
145 %if %{rhel_base_version} >= 700
146 # pidgin has been removed, but libpurple still exists
147 %define has_pidgin 0
148 %endif
149 %endif
150 %endif
152 %if 0%{?purple_sipe_mingw32}
153 Name: mingw32-pidgin-sipe
154 %else
155 %if 0%{?purple_sipe_mingw64}
156 Name: mingw64-pidgin-sipe
157 %else
158 Name: pidgin-sipe
159 %endif
160 %endif
161 Summary: Pidgin protocol plugin to connect to MS Office Communicator
162 Version: 1.23.0
163 Release: 1
164 Source: pidgin-sipe-%{version}.tar.gz
165 Group: %{pkg_group}
166 License: GPLv2+
167 URL: http://sipe.sourceforge.net/
169 BuildRoot: %{_tmppath}/%{name}-%{version}-build
171 %if 0%{?mingw_prefix:1}
173 # Windows cross-compilation build setup
175 BuildArch: noarch
176 #!BuildIgnore: post-build-checks
178 BuildRequires: %{mingw_prefix}filesystem >= 23
179 BuildRequires: %{mingw_prefix}cross-gcc
180 BuildRequires: %{mingw_prefix}cross-binutils
181 BuildRequires: %{mingw_prefix}gettext-runtime
182 BuildRequires: %{mingw_prefix}cross-pkg-config
183 BuildRequires: %{mingw_prefix}glib2-devel >= 2.12.0
184 BuildRequires: %{mingw_prefix}libxml2-devel
185 BuildRequires: %{mingw_prefix}mozilla-nss-devel
186 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.4.0
187 BuildRequires: %{mingw_prefix}cross-nsis
189 # For directory ownership
190 BuildRequires: %{mingw_prefix}pidgin
192 # Make sure telepathy is disabled for Windows builds
193 %undefine build_telepathy
195 %else
197 # Standard Linux build setup
199 BuildRequires: libpurple-devel >= 2.4.0
200 BuildRequires: %{dbus_devel}
201 BuildRequires: libxml2-devel
202 BuildRequires: %{nss_develname}
203 BuildRequires: gettext-devel
204 # The following two are required to enable Voice & Video features
205 %if 0%{?has_libnice:1}
206 BuildRequires: libnice-devel
207 %if 0%{?nice_gstreamer:1}
208 # Dependency required when gstreamer support is split into two packages
209 Requires: %{nice_gstreamer}
210 %endif
211 %endif
212 %if 0%{?has_gstreamer1:1}
213 BuildRequires: pkgconfig(gstreamer-1.0)
214 %else
215 %if 0%{?has_gstreamer:1}
216 BuildRequires: pkgconfig(gstreamer-0.10)
217 %endif
218 %endif
219 %if 0%{?has_farstream:1}
220 BuildRequires: pkgconfig(farstream-0.2)
221 BuildRequires: pkgconfig(gio-2.0)
222 %endif
223 # Requirements for telepathy backend
224 %if 0%{?build_telepathy:1}
225 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
226 BuildRequires: gmime-devel
227 BuildRequires: glib2-devel >= 2.28.0
228 %endif
230 # Configurable components
231 # Use "--without kerberos" to disable krb5
232 %if !0%{?_without_kerberos:1}
233 BuildRequires: krb5-devel
234 %if 0%{?has_gssntlmssp}
235 BuildRequires: gssntlmssp-devel >= 0.5.0
236 Requires: gssntlmssp >= 0.5.0
237 %endif
238 %endif
240 # For directory ownership
241 %if %{has_pidgin}
242 BuildRequires: pidgin
243 Requires: pidgin
244 %endif
245 %if 0%{?build_telepathy:1}
246 BuildRequires: empathy
247 %endif
249 # End Windows cross-compilation/Linux build setup
250 %endif
252 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
253 BuildRequires: libtool
254 BuildRequires: intltool
255 BuildRequires: glib2-devel >= 2.12.0
258 %description
259 A third-party plugin for the Pidgin multi-protocol instant messenger.
260 It implements the extended version of SIP/SIMPLE used by various products:
262 * Skype for Business
263 * Microsoft Office 365
264 * Microsoft Business Productivity Online Suite (BPOS)
265 * Microsoft Lync Server
266 * Microsoft Office Communications Server (OCS 2007/2007 R2)
267 * Microsoft Live Communications Server (LCS 2003/2005)
269 With this plugin you should be able to replace your Microsoft Office
270 Communicator client with Pidgin.
272 This package provides the icon set for Pidgin.
275 %package -n %{purple_plugin}
276 Summary: Libpurple protocol plugin to connect to MS Office Communicator
277 Group: %{pkg_group}
278 License: GPLv2+
279 Obsoletes: purple-sipe
280 %if 0%{?build_telepathy:1}
281 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
282 %endif
284 %description -n %{purple_plugin}
285 A third-party plugin for the Pidgin multi-protocol instant messenger.
286 It implements the extended version of SIP/SIMPLE used by various products:
288 * Skype for Business
289 * Microsoft Office 365
290 * Microsoft Business Productivity Online Suite (BPOS)
291 * Microsoft Lync Server
292 * Microsoft Office Communications Server (OCS 2007/2007 R2)
293 * Microsoft Live Communications Server (LCS 2003/2005)
295 This package provides the protocol plugin for libpurple clients.
298 %if 0%{?build_telepathy:1}
299 %package -n %{empathy_files}
300 Summary: Telepathy connection manager to connect to MS Office Communicator
301 Group: %{pkg_group}
302 License: GPLv2+
303 Requires: empathy
304 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
306 %description -n %{empathy_files}
307 A Telepathy connection manager that implements the extended version of
308 SIP/SIMPLE used by various products:
310 * Skype for Business
311 * Microsoft Office 365
312 * Microsoft Business Productivity Online Suite (BPOS)
313 * Microsoft Lync Server
314 * Microsoft Office Communications Server (OCS 2007/2007 R2)
315 * Microsoft Live Communications Server (LCS 2003/2005)
317 This package provides the icon set for Empathy.
320 %if 0%{?build_ktp:1}
321 %package -n %{ktp_files}
322 Summary: Telepathy connection manager to connect to MS Office Communicator
323 Group: %{pkg_group}
324 License: GPLv2+
325 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
327 %description -n %{ktp_files}
328 A Telepathy connection manager that implements the extended version of
329 SIP/SIMPLE used by various products:
331 * Skype for Business
332 * Microsoft Office 365
333 * Microsoft Business Productivity Online Suite (BPOS)
334 * Microsoft Lync Server
335 * Microsoft Office Communications Server (OCS 2007/2007 R2)
336 * Microsoft Live Communications Server (LCS 2003/2005)
338 This package provides the profile for KTP account manager.
339 %endif
342 %package -n %{telepathy_plugin}
343 Summary: Telepathy connection manager to connect to MS Office Communicator
344 Group: %{pkg_group}
345 License: GPLv2+
346 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
348 %description -n %{telepathy_plugin}
349 A Telepathy connection manager that implements the extended version of
350 SIP/SIMPLE used by various products:
352 * Skype for Business
353 * Microsoft Office 365
354 * Microsoft Business Productivity Online Suite (BPOS)
355 * Microsoft Lync Server
356 * Microsoft Office Communications Server (OCS 2007/2007 R2)
357 * Microsoft Live Communications Server (LCS 2003/2005)
359 This package provides the protocol support for Telepathy clients.
362 %package -n %{common_files}
363 Summary: Common files for SIPE protocol plugins
364 Group: %{pkg_group}
365 License: GPLv2+
366 BuildArch: noarch
368 %description -n %{common_files}
369 This package provides common files for the SIPE protocol plugins:
371 * Localisation
372 %endif
375 %if 0%{?mingw_prefix:1}
376 %package -n %{nsis_package}
377 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
378 Group: %{pkg_group}
379 License: GPLv2+
381 %description -n %{nsis_package}
382 A third-party plugin for the Pidgin multi-protocol instant messenger.
383 It implements the extended version of SIP/SIMPLE used by various products:
385 * Skype for Business
386 * Microsoft Office 365
387 * Microsoft Business Productivity Online Suite (BPOS)
388 * Microsoft Lync Server
389 * Microsoft Office Communications Server (OCS 2007/2007 R2)
390 * Microsoft Live Communications Server (LCS 2003/2005)
392 This package contains the NSIS installer package of the protocol plugin
393 for Pidgin on Windows.
394 %endif
397 %{mingw_debug_package}
400 %prep
401 %setup -q -n pidgin-sipe-%{version}
403 %build
404 %if 0%{?mingw_prefix:1}
406 # Windows cross-compilation build
408 %{?env_options}
409 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
410 autoreconf --verbose --install --force
411 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
412 %{mingw_configure} \
413 --enable-purple \
414 %if 0%{?build_telepathy:1}
415 --enable-telepathy
416 %else
417 --disable-telepathy
418 %endif
419 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
421 %else
423 # Standard Linux build
425 %configure \
426 %if !0%{?_without_kerberos:1}
427 --with-krb5 \
428 %endif
429 --enable-purple \
430 %if 0%{?build_telepathy:1}
431 --enable-telepathy
432 %else
433 --disable-telepathy
434 %endif
435 make %{?_smp_mflags}
436 make %{?_smp_mflags} check
438 # End Windows cross-compilation/Linux build setup
439 %endif
442 %install
443 %if 0%{?mingw_prefix:1}
445 # Windows cross-compilation install
447 %{mingw_makeinstall}
448 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
450 # generate .dbgsym file
451 rm -f %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
452 mv \
453 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
454 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
455 %{__strip} --strip-unneeded \
456 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym \
457 -o %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
459 # generate NSIS installer package
460 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
461 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
462 >%{buildroot}/pidgin-sipe.nsi
464 set -e; \
465 cd %{buildroot}; \
466 makensis \
467 -DPIDGIN_VERSION=UNKNOWN \
468 -DVERSION=%{version} \
469 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
470 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
471 pidgin-sipe.nsi \
473 rm -f %{buildroot}/pidgin-sipe.nsi
475 %else
477 # Standard Linux install
479 %makeinstall
481 # End Windows cross-compilation/Linux build setup
482 %endif
484 find %{buildroot} -type f -name "*.la" -delete -print
485 # SLES11 defines suse_version = 1110
486 %if 0%{?suse_version} && 0%{?suse_version} < 1120
487 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
488 %endif
489 # Pidgin doesn't have 24 or 32 pixel icons
490 rm -f \
491 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
492 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
493 %if !0%{?has_appdata:1}
494 # We don't have AppStream, so we can't package metadata file at all
495 rm -r %{buildroot}/%{_datadir}/appdata
496 %endif
497 %if !%{has_pidgin}
498 # We don't have Pidgin, so we can't package icons at all
499 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin
500 %endif
501 %if 0%{?build_telepathy:1}
502 %if !0%{?build_ktp:1}
503 rm -r %{buildroot}%{_datadir}/telepathy
504 %endif
505 %endif
506 %find_lang pidgin-sipe
509 %clean
510 rm -rf %{buildroot}
513 %if 0%{?build_telepathy:1}
514 %files -n %{purple_plugin}
515 %else
516 %files -n %{purple_plugin} -f pidgin-sipe.lang
517 %endif
518 %defattr(-,root,root,-)
519 %doc AUTHORS ChangeLog COPYING NEWS README TODO
520 %if 0%{?mingw_prefix:1}
521 %{mingw_libdir}/purple-2/libsipe.dll
522 %{mingw_libdir}/purple-2/libsipe.dll.dbgsym
523 %else
524 %{_libdir}/purple-2/libsipe.so
525 %endif
528 %if 0%{?build_telepathy:1}
529 %files -n %{empathy_files}
530 %defattr(-,root,root,-)
531 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
532 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
535 %if 0%{?build_ktp:1}
536 %files -n %{ktp_files}
537 %defattr(-,root,root,-)
538 %doc AUTHORS COPYING
539 %{_datadir}/telepathy/profiles/sipe.profile
540 %endif
543 %files -n %{telepathy_plugin}
544 %defattr(-,root,root,-)
545 %doc AUTHORS ChangeLog COPYING NEWS README TODO
546 %{_datadir}/dbus-1/services/*.sipe.service
547 %{_libexecdir}/telepathy-sipe
550 %files -n %{common_files} -f pidgin-sipe.lang
551 %defattr(-,root,root,-)
552 %endif
555 %files
556 %defattr(-,root,root,-)
557 %doc AUTHORS COPYING
558 %if 0%{?mingw_prefix:1}
559 %if 0%{?has_appdata:1}
560 %{mingw_datadir}/appdata/pidgin-sipe.metainfo.xml
561 %endif
562 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
563 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
564 %else
565 %if %{has_pidgin}
566 %if 0%{?has_appdata:1}
567 %{_datadir}/appdata/%{name}.metainfo.xml
568 %endif
569 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
570 # SLES11 defines suse_version = 1110
571 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
572 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
573 %endif
574 %endif
575 %endif
578 %if 0%{?mingw_prefix:1}
579 %files -n %{nsis_package}
580 %defattr(-, root, root)
581 /pidgin-sipe-%{version}.exe
582 %endif
585 %changelog
586 * DDD MMM DD 2017 J. D. User <jduser@noreply.com> 1.23.0
587 - update to 1.23.0
589 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
590 - add BR dbus-1
591 - fix incorrect BR gstreamer-0.10 when gstreamer-1.0 is selected
593 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
594 - update to 1.22.1
596 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
597 - update to 1.22.0
599 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
600 - add BR gio-2.0
602 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
603 - add BR farstream-0.2
605 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
606 - update to 1.21.1
608 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
609 - update to 1.21.0
611 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
612 - align with Fedora SPEC file
614 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
615 - add AppStream metadata file
617 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
618 - add dependency on pkgconfig(gstreamer-1.0) for F22+ & Leap 42.1+
620 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
621 - update to 1.20.1
623 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
624 - we also support "Skype for Business"
626 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
627 - update to 1.20.0
629 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
630 - update to 1.19.1
632 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
633 - update to 1.19.0
635 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
636 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
638 * Mon Jan 05 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
639 - remove support for obsolete distributions
640 - Fedora < 19
641 - Mandriva
642 - OpenSUSE < 13.x
644 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
645 - update to 1.18.5
647 * Thu Dec 18 2014 J. D. User <jduser@noreply.com> 1.18.4-*git*
648 - improve support for CentOS & Scientific Linux
650 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
651 - update to 1.18.4
653 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
654 - update to 1.18.3
656 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
657 - update to 1.18.2
659 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
660 - update to 1.18.1
662 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
663 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
665 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
666 - update to 1.18.0
668 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
669 - update to 1.17.3
671 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
672 - update to 1.17.2
674 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
675 - update to 1.17.1
677 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
678 - update to 1.17.0
680 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
681 - update to 1.16.1
683 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
684 - update to 1.16.0
686 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
687 - update to 1.15.1
689 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
690 - update package description texts
692 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
693 - update to 1.15.0
695 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
696 - update to 1.14.1
698 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
699 - update to 1.14.0
701 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
702 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
704 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
705 - BR telepathy-glib-devel >= 0.18.0
707 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
708 - BR telepathy-glib-devel >= 0.14.0
710 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
711 - really disable telepathy for Windows cross-compilation builds
713 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
714 - updates to enable telepathy build
716 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
717 - update to 1.13.3
719 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
720 - update to 1.13.2
722 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
723 - update to 1.13.1
725 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
726 - update to 1.13.0
728 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
729 - we do support Microsoft Lync Server 2010 now.
731 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
732 - update GPL2 license name
734 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
735 - add BR gmime-devel for Fedora to have at least one verification platform
737 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
738 - fix Mandriva 2011 unresolvable BR
740 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
741 - add BR nss-devel
743 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
744 - add NSIS package for mingw builds
746 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
747 - add mingw64 build
749 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
750 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
752 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
753 - update mingw32 build
754 - update descriptions
756 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
757 - update to 1.12.0
759 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
760 - add gstreamer-devel to enable Voice & Video features
762 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
763 - add optional subpackage for telepathy connection manager
765 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
766 - update to 1.11.2
768 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
769 - update to 1.11.1
771 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
772 - add mingw32 build configuration
774 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
775 - update to 1.11.0
777 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
778 - Mandriva config for OBS has changed
780 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
781 - add libnice build information discovered through OBS testing
783 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
784 - add NSS build information discovered through OBS testing
786 * Sun Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
787 - release
789 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
790 - Mandriva has too old libtool version
792 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
793 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
795 * Thu Apr 01 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
796 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
798 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
799 - added --enable/--disable build options
801 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
802 - removed --with-krb5 configure option as it is autodetected now
804 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
805 - add SVG icon
807 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
808 - add BR glib2-devel >= 2.12.0
810 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
811 - add tests to build
813 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
814 - update to 1.9.1
816 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
817 - add BR libxml2-devel
819 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
820 - release
821 - dropped SLE 10 due to libpurple min version increase
822 - updated target distros in comment line
824 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
825 - increased libpurple build requisite to >= 2.4.0
827 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
828 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
830 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
831 - sync with RPM SPEC from contrib/rpm
833 * Mon Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
834 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
835 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
837 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
838 - reinstated enable-quality-check
840 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
841 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
843 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
844 - Spec file modifications for openSUSE build service
846 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
847 - move non-Pidgin files to new sub-package purple-sipe
849 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
850 - remove directory for emoticon theme icons
852 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
853 - libpurple protocol plugins are located under %%{_libdir}/purple-2
855 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
856 - added directory for emoticon theme icons
858 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
859 - update to 1.6.3
861 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
862 - reduce libpurple-devel requirement to >= 2.3.1
864 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
865 - update to 1.6.2
867 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
868 - reduce libpurple-devel requirement to >= 2.4.1
870 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
871 - com_err.h only required for kerberos
873 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
874 - require libpurple-devel >= 2.5.0
876 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
877 - refactor configure parameters
878 - make kerberos configurable
879 - don't hard code prefix for git builds
881 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
882 - removed unnecessary zlib-devel
884 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
885 - fix prefix for git builds
887 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
888 - append -Wno-unused-parameter for GCC <4.4 compilation errors
890 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
891 - remove duplicate GPL2
893 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
894 - use "--with git" to build from git
895 - corrected download URL for release archive
896 - add missing BR gettext-devel
898 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
899 - use default rpmbuild CFLAGS also for git builds
900 - merge with SPEC files created by mricon & jberanek
902 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
903 - initial RPM SPEC example generated